Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I read my emails sonce the latest Firefox upgrade?

  • 8 replies
  • 55 have this problem
  • 36 views
  • Last reply by Boothy99

more options

I am in UK and use Virgin Media's email service with a blueyonder mail address. Since Firefox was updated very recently I can still log in to email but I cannot read the contents of the message, I get a blank screen wit the email title only. If I choose to print the email, I can then read the text. If I log in using Internet Explorer I can read emails with no problem. Has anyone else had this problem and managed to sort it? Thanks - Alan Thompson

I am in UK and use Virgin Media's email service with a blueyonder mail address. Since Firefox was updated very recently I can still log in to email but I cannot read the contents of the message, I get a blank screen wit the email title only. If I choose to print the email, I can then read the text. If I log in using Internet Explorer I can read emails with no problem. Has anyone else had this problem and managed to sort it? Thanks - Alan Thompson

Chosen solution

None of the suggestions worked for me but thanks to everyone for their efforts. I think I saw a suggestion to upgrade to Firefox 8 - I have done this and it has fixed the problem.

Read this answer in context 👍 0

All Replies (8)

more options

Probably applies to your email sound like it uses the GMail processing:

GMail entire message content missing (blank) after header title

In Firefox, if you have "Adblock Plus" extension.

  1. "Ctrl+Shift+F" Preferences (or right click on ADP symbol, and choose preferences)
  2. 'Filters' menu > "Update all subscriptions"

reference: https://support.mozilla.com/questions/896267

more options

Try the solition from here: https://support.mozilla.com/pl/questions/893645 by dmcritchie

Also try to search first for already asked questions.

more options

I had the above fault with Google mail and updated 'adblock' as suggested, it appears to have fixed it!

to add the adblock fix worked for Google Mail, but not in Virgin Mail, I had to turn off Adblock completely, as the update did not work!

thanks

Modified by kelvinfagan

more options

Also please don't forget to mark question as "solved" by selecting the answer that helped you.

more options

So turning off ADP worked for Virgin mail, so you know you are close to a solution, see the additional comments(s) on how to check your Adblock filters in the link originally referenced or in the MozillaZine article itself. (both references are here)

If you come up with a solution for Virgin please indicate what it is.

more options

I've just spent about 3 hours trying to resolve this issue with my ntlworld.com (part of Virgin Media) email addresses. The suggestion to update subcriptions didn't work for me nor did anything else suggested in other replies to similar questions in Firefox Help.

I got my email working again by changing the subscription filter list I'm using in Adblock Plus. I added EasyList (English) to my filters list and disabled Fanboy's List (English). I then disabled Adblock, restarted Firefox, enabled Adblock, restarted Firefox again. Bingo. Email I can read without using another browser.

more options

Chosen Solution

None of the suggestions worked for me but thanks to everyone for their efforts. I think I saw a suggestion to upgrade to Firefox 8 - I have done this and it has fixed the problem.

more options

Adblock plus / Fanboy's List was causing the issue for me....

Open up Virgin mail - log in and open a message (should be blank message window at this point), so that Adblock recognises a hit.

Click Firefox tools / add-ons / extensions / Adblock plus & open Options.

Now with the Adblock's Preferences window open, ... click the top right - on the heading Hits, until it's arrow is pointing down (to give most hits at the top of the list).

You should see near the top (IF you loaded a Virgin mail message first!), a filter with a very long name, starting with ~t-mobile.co.uk, ~channel4.com, ~amusingplanet.com..... etc, etc.

Now, un-tick that filter (disabled) / Apply / OK, to close Adblock Plus Prefferences.

Go back to Virgin mail and reload or open a message, and it SHOULD be fixed. Was for me anyways  :O)

See Image attachment.

Modified by Boothy99