X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 8.0, refuses to recognize up-to-date flash player

Posted

Running 8.0 on windows. Flash has totally stopped working. Updating flash does nothing, uninstalling and reinstalling flash does nothing. It also tells me that it has been "Disabled for my safety" because I'm using an "outdated version" even though I just updated it. How do I fix this?

Chosen solution

There are 2 versions of Adobe Flash:

  • an ActiveX version for IE only
  • a Plugin version for most other browsers including Firefox
  • On a Windows system, you should always update both individually.

You do not appear to have the Plugin version for Firefox installed. If you did, in Add-ons > Plugins you would see "Shockwave Flash (version)". If "Shockwave Flash" is there and is disabled, click the "Enable" button. NOTE: Yes, I saw that you said it was disabled. The current version, just released a couple of days ago is 11.1.102.55.

Check your Plugins often --> http://www.mozilla.org/en-US/plugincheck/

  • only the most popular/used Plugins are known by this page
  • page will detect only installed, enabled Plugins

Install or update Adobe Flash

  1. Using Firefox, go to the following link and SAVE the download to your desktop so you can find it later. Un-check any items on that page that you do not want to download (i.e., "McAfee Security Scan Plus":
  2. When the download is finished, close Firefox (File > Exit OR Firefox button > Exit)
  3. Click or double-click on the file you just saved to your desktop
    • In the installation window that appears, click the box to the left of "I have read and...." to place a check mark in the box
    • The "Install" button in the lower right corner will now be highlighted, click it.
    • The installation is quick.
  4. Start Firefox and test your installation here: https://www.adobe.com/software/flash/about/
  5. To update/install the ActiveX version for IE only, repeat the process, but use IE to go to the above website.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Adobe Shockwave for Director Netscape plug-in, version 11.6.3.633
  • Google Update
  • 4.0.60831.0
  • DivX VOD Helper Plug-in
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Best Buy pc app Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

SafeBrowser 550 solutions 2392 answers

Chosen Solution

There are 2 versions of Adobe Flash:

  • an ActiveX version for IE only
  • a Plugin version for most other browsers including Firefox
  • On a Windows system, you should always update both individually.

You do not appear to have the Plugin version for Firefox installed. If you did, in Add-ons > Plugins you would see "Shockwave Flash (version)". If "Shockwave Flash" is there and is disabled, click the "Enable" button. NOTE: Yes, I saw that you said it was disabled. The current version, just released a couple of days ago is 11.1.102.55.

Check your Plugins often --> http://www.mozilla.org/en-US/plugincheck/

  • only the most popular/used Plugins are known by this page
  • page will detect only installed, enabled Plugins

Install or update Adobe Flash

  1. Using Firefox, go to the following link and SAVE the download to your desktop so you can find it later. Un-check any items on that page that you do not want to download (i.e., "McAfee Security Scan Plus":
  2. When the download is finished, close Firefox (File > Exit OR Firefox button > Exit)
  3. Click or double-click on the file you just saved to your desktop
    • In the installation window that appears, click the box to the left of "I have read and...." to place a check mark in the box
    • The "Install" button in the lower right corner will now be highlighted, click it.
    • The installation is quick.
  4. Start Firefox and test your installation here: https://www.adobe.com/software/flash/about/
  5. To update/install the ActiveX version for IE only, repeat the process, but use IE to go to the above website.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

Modified by SafeBrowser

Oxylatium 44 solutions 273 answers

Hello.

There is a workaround:

The Flash plugin should be listed and enabled in the plugin manager of Firefox.

SafeBrowser 550 solutions 2392 answers

It is not necessary to downgrade to Firefox 7.0.1 to get Adobe Flashplayer installed. Just follow the steps in my post above. The original poster, DoctorCrow, marked the answer that I supplied as solving the problem without all the extra downgrade/upgrade steps.

ahabse7en 0 solutions 2 answers

Helpful Reply

Unfortunately both solutions/workarounds provided here didn't help me with what seemed to be the same problem as the original poster. What did help me was a solution provided here: http://support.mozilla.com/en-US/ques.../849425

In short the solution suggested was to copy the NPSWF32.dll file found in the directory (at least on my system):

C:\Windows\SysWOW64\Macromed\Flash\NPSWF32.dll

to my firefox plugins folder found here (again location may differ for you):

C:\Program Files (x86)\Mozilla Firefox\Plugins

As soon as I did that Flash was working again in FF 8.0.

SafeBrowser 550 solutions 2392 answers

Copying the Flash .dll file to the Firefox programs plugins folder will work, but

  • you will need to remove that when you update Flash
  • you may end up with 2 conflicting Flash plugins in the future if you lease the .dll file in the Firefox program plugins folder

It is best to get Flash working from its default installation folder


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Oxylatium 44 solutions 273 answers

Be sure you installed the Flash 32-bits plugin, because Firefox is a 32-bits application on Windows. Remove current Flash EXEs and go to here: http://kb2.adobe.com/cps/191/tn_19166.html#main_Install_in_a_firewall_proxy_server_environment They download the link 32 bit Flash Player Plug-in (All other browsers). The plugin should appear in the plugin manager.