Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

will roboform 6 work with the latest firefox

  • 1 reply
  • 3 have this problem
  • 6 views
  • Last reply by ideato

more options

I have the paid for version of roboform 6 and do not intend to pay for their latest version. I am using firefox 3.6 but keep being nagged to upgrade to the latest version. If I cannot use roboform with the latest version I will look for a browser that can.

Chosen solution

No, RoboForm ver 6 supports only Firefox ver 3.

read here(RoboForm versions vs Firefox versions) for more info:

http://www.roboform.com/platforms/browsers/firefox


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

No, RoboForm ver 6 supports only Firefox ver 3.

read here(RoboForm versions vs Firefox versions) for more info:

http://www.roboform.com/platforms/browsers/firefox


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.