Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I get Firefox 8 to recognize the filetype of downloadable attachments on php boards?

  • 10 replies
  • 72 have this problem
  • 32 views
  • Last reply by jc5u

more options

After updating to Firefox 8, attachments on php boards (such mp3s or image files) are not recognized filetypes. When I click on them, or right click "save link as", the save window shows the attachment as "Index.php" and only offers to save it as a php file. I have to manually type in the file name and extension and select "All files" under file type to get it to save correctly. This has been happening only since Firefox updated itself to version 8.0. IE still works normally with attachments on php boards, so it's not site problems. Is there some setting, or configuration I can change to fix this? Thanks, Mark

After updating to Firefox 8, attachments on php boards (such mp3s or image files) are not recognized filetypes. When I click on them, or right click "save link as", the save window shows the attachment as "Index.php" and only offers to save it as a php file. I have to manually type in the file name and extension and select "All files" under file type to get it to save correctly. This has been happening only since Firefox updated itself to version 8.0. IE still works normally with attachments on php boards, so it's not site problems. Is there some setting, or configuration I can change to fix this? Thanks, Mark

All Replies (10)

more options

Try the Firefox SafeMode to see how it works there.
A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  • You can open the Firefox 4/5/6/7 SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

Don't select anything right now, just use "Continue in SafeMode."

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

more options

Thanks for your reply edmeister,

I tried your suggestions, but I still have the same problem. Safe mode didn't make any difference. I was using another theme and I did have a couple of extensions enabled, but I have since disabled them and reverted to the default theme. A friend suggested checking file associations in Firefox, but that didn't help either. I tried setting mp3 and jpeg image to "save" rather than "Always ask" but it made no difference (probably because FF sees those attachments as php files, rather than audio and image files). But I also noticed that in that Open/Save dialogue that opens when I click on an attachment, the option "Do this automatically for files of this type from now on" is now greyed out. I've attached a screenshot of the Open/Save dialogue to show you what happens when I click on an mp3 attachment on a music forum I belong to (note: IE recognizes this attachment as an mp3 ).

I tried removing all cookies and history and emptying the cache. I also ran CCleaner to check for registry issues, then rebooted. Still no luck.

more options

It looks like it's a known problem with Firefox 8 and SMF boards... including the Simple Machines board itself. Here is a link to a post about it. There are 2 more links on that page, eventually leading to a bugzilla post from September.

There is a code in that first link that is supposed to fix it, so admins of SMF boards may have to use that, at least for the time being.

Modified by Liquid

more options

I just "upgraded" to FireFox 8 about 1/2 hour ago. The first .PDF file I tried to download was downloaded as "index.php." Then, trying another one, same deal. Now I find that ALL .PDF files I try to download are downloaded as "index.php" files! Which is no help at all.

So, in troubleshooting, I went to the same website with Safari, and downloaded the PDF file just fine.

Tried to follow the suggestion above to go the the Simple Machines board, but found that I have to register for it too, just to see a post. Nuts! I hate upgrades that breaks stuff...

Don't developers test their upgrades before releasing them?? Is FireFox now a dead issue because if it doesn't work, I'll delete it and use something else... (and I'm sure I'm not alone).

more options

We changed the handling of the content-disposition (attachments information) to be more compliant with the official webstandards (RFCs). We do not want to be the only browser who is having different rules for this. So it had to change anyway. According to the bugzilla report SM had a patch for this ready but forgot to add it to the latest update. So they are working on a fix.

more options

Thanks for the info, knorretje.

I will tell the admin of my forum to keep an eye out for the latest update. He might want to try the current patch in the meantime. Cheers

@ gto49 Once the websites using SMF implement the patch, or update to the latest version of SMF (once it's released) the problem should be fixed.

more options

To fix this problem have to form response header the same as in IE:

attachment; filename="FileName.extension"

For previous versions of FireFox there were with '*':

attachment; filename*="FileName.extension"
more options

I would prefer to follow the official syntax from RFC5987 for the extended parameters, so you can still use extended characters from Latin-1 or UTF-8. If you use the regular parameter form without the "*" then you can only use characters inside the ascii range.

more options

So until that happens (all the BBs upgrade their boards), it would be better to roll back our 'upgraded' version of FireFox then?... at least we can access material unhindered.

more options

I bet this will affect Mozilla's market share. Everyone I see complaining about this thinks that it is a bug in Mozilla. Many are changing to new browsers.