X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Latest Firefox update compatible with Mac Tiger OSX 10.4.11

Posted

Firefox notifies me that I'm not running the latest version (I have 3.6.24 GTB7.1) and to download the version compatible with my older system (Mac Tiger 10.4.11). I click on that link and can find nothing that states what systems the version(s) there are compatible with. I have in the past downloaded and installed an incompatible version, a situation to avoid for obvious reasons.

Bob Hunt

Chosen solution

You have the latest version of Firefox for PPC Macs and for 10.4.11, the Firefox 4+ versions require Intel and 10.5.8 or higher.

For older Macs that aren't supported in Firefox 4 thru 8, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/

http://tenfourfox.blogspot.com/

Read this answer in context 6

Additional System Details

This happened

Just once or twice

This started when...

This has been an ongoing problem for some time

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Java 1.3.1 Plug-in
  • iPhoto6 [iPhoto 7.1.5 and I run some Classic programs from time to time, but don't use browsers in System 9.2]
  • DivX Web Player version 1.4.0.233
  • Office Live Update v1.0
  • Shockwave Flash 10.1 r53
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • LogMeIn remote control components
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.24) Gecko/20111103 Firefox/3.6.24 GTB7.1

More Information

I have searched for Mac system compatibility of any versions and gotten no returns. I believe it's there, I just can't find it.

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24405 answers

Chosen Solution

You have the latest version of Firefox for PPC Macs and for 10.4.11, the Firefox 4+ versions require Intel and 10.5.8 or higher.

For older Macs that aren't supported in Firefox 4 thru 8, try TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/

http://tenfourfox.blogspot.com/

Helpful Reply

Thanks for the fast responses, I am particularly happy to have found the floodgap.com website. Didn't think that I was the only one muttering about the abandonment of two decades of pre-Intel software and tech files that my work depends on, and am glad to see some action in that direction. Surely a cottage industry will spring up to keep hardware available. I love what Apple has brought us but not their ability to turn their back on what brought them up, and millions of users in the process.

dickguertin 1 solutions 20 answers

What's available for 10.4.11 on an Intel-based Mac-Mini? What Firefox version works for that machine/system?