X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 8 is slow to show the web page when requested. If I hilite the address in the URL address line it usually downloads the info right away. I find this gets slowers as time goes on.

Posted

the browser is started home page loads up. but if I request to go to a web page it shows that the request is asking for my request in the new tab but it just sits there. If I go to the address HTTP bar and hit enter again I usually get the info right away

Modified by Calitiki

Chosen solution

I have loved Firefox, but 8.0 is an abomination on loading. Half the time a blank screen comes up. Pages on amazon and newegg, among others stall out.

No problems with IE8 on same sites. I downgraded to FF 7.0.1 and same problem.

I just went back to 3.6.8. Guess what -- no problems. Someone has messed up big time with Firefox after 3.6.8. If you can't fix the problems and have security problems with 3.6.8, then maybe we may have to go back to IE (shudder). As it is, Firefox 8.0.1 is not workable and is toast for me until fixed.

Read this answer in context 28

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Shockwave Flash 11.0 r1
  • Shockwave Flash 11.2 d202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.669
  • GEPlugin
  • WordCaptureX component for single click dictionary
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • 4.0.60831.0
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • Next Generation Java Plug-in 10.0.0 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • BlackBerry WebSL Browser Plug-In
  • iTunes Detector Plug-in
  • NPWLPG
  • Picasa plugin
  • MeadCo's Neptune

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

I down loaded Waterfox the 64 bit Firefox browser and it has solved the problems Thanks for all your help

akayz 1 solutions 5 answers

I found that it just crashed after a while, then started working.

Solution: Uninstall Firefox 8 and get Firefox 7 until this issue dies down.

wizbangboom 0 solutions 2 answers

I upgraded to 9 Beta. A little faster, still issues with some sites and has the same problem with sites with a lot of graphics, which I think is the problem. Sites with few graphics and lotsa text no problem.

wizbangboom 0 solutions 2 answers

http://www.latimes.com refuses to load. Fix this and you resolve the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

The default of the pref network.http.max-connections has been increased from 30 to 256 in Firefox 6+ versions.

Try to decrease the value of the pref network.http.max-connections from 256 to 30 as used in Firefox 3 versions.

ralphbusdriver 0 solutions 19 answers

This is an old "solution", and doesn't work.

Modified by ralphbusdriver

matrixunloaded 1 solutions 3 answers

Chosen Solution

I have loved Firefox, but 8.0 is an abomination on loading. Half the time a blank screen comes up. Pages on amazon and newegg, among others stall out.

No problems with IE8 on same sites. I downgraded to FF 7.0.1 and same problem.

I just went back to 3.6.8. Guess what -- no problems. Someone has messed up big time with Firefox after 3.6.8. If you can't fix the problems and have security problems with 3.6.8, then maybe we may have to go back to IE (shudder). As it is, Firefox 8.0.1 is not workable and is toast for me until fixed.

matrixunloaded 1 solutions 3 answers

This didn't work. Only thing that worked is to go back to 3.6.8 release.

matrixunloaded 1 solutions 3 answers

I tried this and same slow or non load problems. I went back to 3.6.8 until this issue is officially fixed.

BTW, no problems with IE 8 (and I hate having to go to it because of this).

ralphbusdriver 0 solutions 19 answers

I agree - the problems showed up in ALL releases after FF 3.6.8. I have Windows Vista and wonder if the FF versions starting with 4 only work well with Windows 7.

justme1 0 solutions 1 answers

SOLVED Hi, I solved this problem by useing xp TCIP repair, its free to use. it found a bad value in my system and repaired it and now everything is working fine again.

reset Linkage\UpperBind for PCI\VEN_8086&DEV_109A&SUBSYS_01D11028&REV_01\4&22443A69&0&00E5. bad value was:

           REG_MULTI_SZ =
               afw

http://download.cnet.com/XP-TCP-IP-Repair/3000-2094_4-10410929.html Hope this helps!

Modified by justme1

xladyvader 0 solutions 1 answers

I have this problem as well. We have Windows 7 64 bit installed and the web is still pokey. I downgraded to FF 3.6.8 but I still see the issue. Anyone else have any other ideas?

Question owner

I use Firefox 3.6.8 on one Win 7 computer and it has solved all the problems. On my main computer Win 7 64 bit I use Firefox Waterfox which is Firefox 64 bit browser and it seems to work very fast. I will keep these 2 and see which is the best

hathar 0 solutions 1 answers

I have just been upgrading since Firefox 3.0 I found that there were errors from all the upgrades with add ons causing slow loading . Try uninstalling and reinstalling Firefox 8. That fixed the speed issue i had now pages are loading fast again.

MizLiz 1 solutions 32 answers

Oh gee, this looks like a dandy way to f*ck up your computer unless you are a guru of sorts.

I hate go to to Google Chrome, but i may have to. Every single version since 5.0 SUCKS royal. And on top of everything else, I'll be doing things online and all of a sudden the screen slowly fades to white. Then you have a choice of closing or crashing. Thanks again, Mozilla.

gai38 0 solutions 1 answers

If you regularly updated FF over old versions your prefs.js looks like a big trash can with bunch of old settings. Close your FF, go to Profile, delete or rename prefs.js and ( if you have it) user.js and restart FF, that will recreate new prefs.js. Open Tools - Options and configure FF manually, if you don't like default settings. Make a favor yourself and don't edit prefs.js. Better you can do all of your changes using user.js. Install Chromedit Plus extension for it and modify your settings in user.js. I had problems above on Windows 7 x64 and Windows XP SP3 machines, but deleting prefs.js and user.js fixed it. Don't blame FF for your trash.

Modified by gai38

luckydog2 0 solutions 1 answers

Helpful Reply

I have Windows 7 (64 bit) Home Premium with Firefox 8.0.1 and I am not a guru, but I resolved the problem as follows. Hope it works for others as well. Open Firefox and select 'Help' on the top line. In the drop down box select 'Restart with add-ons disabled' This opens Firefox in Safe Mode (Firefox's own Safe Mode, not Windows Safe Mode) Place a tick in 'Reset all user preferences to Firefox defaults' and then click on 'Make changes and restart' This took me to the Firefox start page so I closed both tabs and re-opened Firefox. Now for me, Firefox did not open to my normal homepage choice of Google, but to that of search engine that I also have loaded. To rectify this I went to 'Tools', then 'Options' (opening on the 'General' tab) where I made Google my home page. On the same page I then noticed that my normal choice of 'Save file to' Desktop had been changed to Downloads, so I corrected this using 'Browse' and clicked on 'OK' I was then taken to a screen which stated that I needed to add a feature, and 'EasyList (English)' was one of the recommended choices. I am sorry that I did not record at the time any further information on what 'EasyList (English) was, or did, but I installed it, closed Firefox and re-opened it. Firefox 8 is now functioning like greased weasel dung off a hot shovel, and all my problems, as listed by many other posters, have all disappeared. I hope this works as well for you as it did for me.

LesMizzell 0 solutions 2 answers

I'm also have the problem of certain pages either never loading at all, or partially loading and then just sitting there without completion. While waiting on Firefox, I can open Opera, Chrome, and/or IE and load the page in question immediately.

Disabling plugins isn't really fixing the problem either. I only use Firebug and the Web Developer tools. Those aren't that big of a load.

From what I've observed, the problem ONLY happens on sites with a lot of "external to this site" http requests. A really good example is the Cheezburger network. There's a ton of affiliate advertising on the site. Typically, a Cheezburger pages will load partially for me, then sit there and never complete. Most similiar sites with a lot of externally called advertising links do the same thing.

Here's some stats from pages I have problems with in Firefox, but load fine in other browsers:

Cheezburger front page (http://icanhascheezburger.com/). 320 http requests Never completes

http://www.nytimes.com/ 202 http requests Never completes

http://news.cnet.com/8301-1035_3-57333829-94/remember-the-cisco-tablet-more-are-on-the-way/ 307 http request doesn't load at all - displays blank page


"Heavy" Sites with a lot of graphic content and such will actually load fine for me, as long as the majority of the material on the site is internal to that specific site.

ralphbusdriver 0 solutions 19 answers

As of today there are nearly 400 people who have found this site and said they have the same problem. FF 9 beta is no better. There are dozens of attempted "fixes" scattered around in various sites - none which have worked for me. Here is an addon which MIGHT work for some: https://addons.mozilla.org/en-US/firefox/addon/memory-fox/?src=search

Mozilla FF needs a tool for individuals to use to see where the bottlenecks are. The problem is universal as posted here:

http://www.bhall.com/2011/11/beginning-of-end-for-firefox.html

Modified by ralphbusdriver

LesMizzell 0 solutions 2 answers

As a developer, I use a number of browsers on both PC and Mac while developing sites for my clients. Firefox has always been my main browser.

As of late though, the loading problem has become a big enough issue for me that Firefox is now regulated to another one of me "testing" browsers, and I'm migrating everything over to Chrome as my main browser of choice.

For example, I just tried to purchase airline tickets for a trip, and the Travelocity search results page simply refused to ever complete in Firefox. Same search in Chrome - WHILE waiting to see what Firefox would do - almost instant.

Honestly, I feel a certain amount of guilt/shame in switching! Hopefully this issue will receive a fix soon.

grman 0 solutions 2 answers

Big pages not rendering until completely or nearly completely downloaded. Has firefox abandoned dialup users? With all the blogs and huge single page sites this problem makes firefox unusable. Let's use google sketchup's blog as an example. this is one of the pages which takes forever to display ANYTHING. http://sketchupdate.blogspot.com/ monitoring task manager's display of my network connection I can see it is downloading at full speed. But I sit there for 5 minutes looking at absolutely NOTHING! A blank page. I have found 2 workarounds. None of the solutions I find posted on the net for about:config help at all. the workarounds: 1. switch to opera 2. disconnect yep, right click the network connection in the system tray and disconnect! the page will display immediately! Well, whatever firefox has of the page so far. then reconnect to finish downloading the page. How annoying is this? This shows that firefox does indeed have enough info to display the page partially while it finishes downloading. nearly 600 people visited this thread. I suspect many more have the problem. Why does firefox ignore this?