Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why won't my accounts log out when I quit Firefox?

  • 3 replies
  • 55 have this problem
  • 5289 views
  • Last reply by xr417

more options

When I quit Firefox my accounts like Gmail and Facebook stay logged in. I want Firefox to remember the username, but I want it to log out when I exit. It used to but then suddenly it stopped and now I have to remember to do it every time. I tried different things in options and privacy but it didn't work

Chosen solution

You can adopt the following methods;

You don't need to be in private browsing mode.

about:config

browser.sessionstore.privacy_level set it's value to 1

{It may not work for all HTTPS sites but I have tested it on facebook,gmail and it worked.}

signon.autofillForms {double click it to set it's value false}

{Prevents auto fill up of forms.Firefox won't autofill the name and password. You need to open the name list with a double click in the name empty field.}

browser.tabs.warnOnClose {Make sure it's boolean value is true.}


about:sessionrestore {For session restore.}

Read this answer in context 👍 3

All Replies (3)

more options

If your Firefox has already stored your log in information for sites like Gmail, Facebook,etc. then you can use private browsing so that you will be logged out automatically after you close Firefox. To enable private browsing press CTRL+SHIFT+P.

more options

I haven't saved any passwords and sometimes when I exit I haven't finished my work. I tried Private browsing and it exited all my tabs and didn't prompt me if I wanted to save my tabs. I want to save my tabs that I'm using for the next time that I enter Firefox, but I want it to log out of my email and Facebook accounts in case I forget. Even though this is a personal computer sometimes other family members do use it.

more options

Chosen Solution

You can adopt the following methods;

You don't need to be in private browsing mode.

about:config

browser.sessionstore.privacy_level set it's value to 1

{It may not work for all HTTPS sites but I have tested it on facebook,gmail and it worked.}

signon.autofillForms {double click it to set it's value false}

{Prevents auto fill up of forms.Firefox won't autofill the name and password. You need to open the name list with a double click in the name empty field.}

browser.tabs.warnOnClose {Make sure it's boolean value is true.}


about:sessionrestore {For session restore.}

Modified by xr417