Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I close my browser, firefox does not log me out of gmail even though I did not check "remember me" when I logged in.

  • 5 replies
  • 6 have this problem
  • 43 views
  • Last reply by cor-el

more options

Just what the question says - my browser won't log me out of gmail when I close my browser. I have cleared all cookies/cache, restarted my computer, logged in several times WITHOUT checking the "remember me" box and it still remembers me. This never used to happen but has only started happening recently.

Just what the question says - my browser won't log me out of gmail when I close my browser. I have cleared all cookies/cache, restarted my computer, logged in several times WITHOUT checking the "remember me" box and it still remembers me. This never used to happen but has only started happening recently.

Chosen solution

In Options -> General , do you have Firefox set to ' show my Windows and Tabs from last time '? If so, this restores your last browsing session, as if you had not closed the browser.

If you choose a homepage to display at startup, your previous session should be removed as usual (although it may still be recovered for a short period with History -> Restore Previous Session).

Read this answer in context 👍 1

All Replies (5)

more options

Chosen Solution

In Options -> General , do you have Firefox set to ' show my Windows and Tabs from last time '? If so, this restores your last browsing session, as if you had not closed the browser.

If you choose a homepage to display at startup, your previous session should be removed as usual (although it may still be recovered for a short period with History -> Restore Previous Session).

more options

Got it, this is definitely what the issue is.

I would love to be able to just open the windows as they were open last time but not with the same session (like it used to be I'm pretty sure). I use chrome at work and this is how chrome behaves and I like it! It's a huge security risk to have the session stay alive even if you close down your computer just with this one setting!

Let's say you have a laptop with this setting on and you're logged into gmail but you turn you laptop off. Then, if your laptop gets stolen, someone could easily log into your gmail simply by firing up your browser even if you didn't check "remember me"!!! Where can I report this/suggest this change?

more options

I agree, it's not ideal. There's already a bug filed for it, although it is labelled WONTFIX. It may yet be opened again- it's been back and forth a few times already as they try to weigh up security vs usefulness. The last commenter (#61) appears to have opened a new bug, so the issue isn't dead yet!

There's an add-on called Session Manager which may do what you're looking for, or there's a setting (detailed in comment #48 of the bug report above) where Firefox will restore the tabs but not the associated cookies. This setting is changed by 'visiting' about:config.

Hope that helps.

more options

Definitely does. Best support I've received for an issue (any issue with anything ever) in a very long time, thanks! :)

Modified by pikes

more options

You can set the pref browser.sessionstore.privacy_level to 2 (never) or 1 (non-HTTPS, default in Firefox 3 versions) on the about:config page to disable saving cookies via session restore.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold (user set).
  • Preferences can be reset to the default via the right-click context menu if they are user set
  • Preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean)