X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I recover accidentally deleted Certificate Authority?

Posted

Hi,

Running Firefox 5 on Ubuntu 10.10 and while troubleshooting some other issues, I believe I have deleted a Certificate Authority accidentally. Because of this I cannot securely access Facebook or any https Google sites. I can, however, access Bank of America and other https sites no problem.

Also, I can access these sites in Chrome without issue (but I prefer Firefox).

I'm looking for a way to recreate or repopulate the CAs. I tried uninstalling/reinstalling Firefox but that didn't seem to work. I'm at the point where I feel like I'll have to reinstall the OS, but I don't want to get to that point if at all possible.

Any ideas much appreciated.

Regards, Joe

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • interneTIFF Internet Imaging
  • iTunes Detector Plug-in
  • 4.0.60531.0
  • BlackBerry WebSL Browser Plug-In
  • Citrix ICA Client Plugin (Win32)
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Helpful Reply

Which error do you get and who is the issuer of the certificates that do not work?

You can only remove trust bits from build-in root certificates.

Try to Rename or remove secmod.db (secmod.db.old) in the Firefox Profile Folder.

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

You may have to rename cert8.db (cert8.db.old) as well.
Firefox will create new files.

Question owner

cor-el,

That seems to have done the trick. Thanks for the assist.

JJJ

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

You're welcome

sharpie8 0 solutions 1 answers

Helpful Reply

Thanks for your helpful information! I think you just solved a similar problem I've been having for quite awhile.

Jefreestyles 0 solutions 1 answers

Thank you so much, cor-el! Your steps worked like a charm. I renamed secmod.db to secmod-old.db, closed Firefox, and renamed cert8.db to cert8-old.db. Now when I opened up Firefox, Google Accounts and our JIRA helpdesk site opened up just fine.

A story should be told on how you managed to figure this out.