Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not rendering italic text

  • 11 replies
  • 26 have this problem
  • 351 views
  • Last reply by alephcat

more options

I can't pinpoint specifically when this began, but this is an issue I've only seen after doing a fresh install of Ubuntu 11.04. Firefox isn't rendering text that appears between <i> and <cite> tags (there may be others that would render as italicized text by default, but I haven't checked), but is correctly rendering text between <em> tags. The text is literally just gone but is taking up space in the layout.

Chrome on the same machine isn't having the same problem

Modified by cor-el

All Replies (11)

more options

Works for me on Linux.
That is usually caused by a problem with the font.

Did you try to use another font?


data:text/html;charset=utf-8,<i>This is a test for Italic text</i><br><cite>This is a test for Italic text</cite>
more options

I'm noticing this across the web on various websites that I don't control. The thing that perplexes me is that the same website will render fine in Chrome. I'd imagine Chrome would be using the same font files that Firefox would be using.

Also, there are sometimes issues with Firefox rendering pages correctly if I Ctrl+click a link to open them up in a new tab. The layout issue fixes itself if I refresh the page exactly twice.

I've got a feeling the two problems are related. Attached are screenshots.

Modified by astrochase

more options

Apparently you can only upload one image per reply, so here's the second one.

more options

Looks fine here.

There isn't a font specified on that page, so the default font is used.

  • Edit > Preferences > Content : Fonts & Colors > Advanced

(you can add more images, but it can take some time to see them appear if you edit your post to add them) (I've removed the two extra images in the first post)

Modified by cor-el

more options

That second screenshot looks really bad.

Did you try a different default font?

more options

A different default font does fix it for the first page. For others where the font family is specified (i.e. Wikipedia) the problem persists, so perhaps there's a problem with the default serif font. This is strange though because I'd have assumed Chrome uses the same one.

The layout issue persists however. Perhaps they're coincidental, rather than related. I can't find any other reference to this problem or bug reports, which would be strange as my setup is relatively common.

Thanks for removing the duplicate screenshots.

Modified by astrochase

more options

You can do a font test to see if you can identify corrupted font(s).

more options

Hi,

same problem here, after upgrade to Kubuntu 11.10, firefox 7.0.1. After I noticed that the "Modified 12 octobre 2011 20:54:58 -0700 by astrochase" above is displayed properly from my firefox, I made some tries on a simple html, with a css style for the italic part. Here is the result: - italic is not displayed when using a class like {font-style:italic;} (i.e. default font is used). - if I add a font-family to the class, then it depends on the font: {font-style:italic;font-family:'Times';} works. Same with Arial, Trebuchet or Verdana, FreeSerif, Liberation Mono. On the contrary, DejaVu Sans does not work.

more options

Hi again,

I just noticed that i've got some problems of display of italics here and there on other applications, so maybe not a firefox problem...

more options

This is truly a bizarre problem...

Attached is the site mentioned by cor-el, shown both in chromium and firefox 8.0 using kubuntu 11.10

Looks like I'll be forced to use chromium until this is fixed, as reading the contents of sites is impossible.

more options

It seem that in the latest versions of (k)ubuntu only ttf-dejavu-core is installed by default. If you install ttf-dejavu-extra [ sudo apt-get install ttf-dejavu-extra ] that fixes the problem for me