X
Tap here to go to the mobile version of the site.

Support Forum

is there still a version of firefox to downlosd for mac os 10.4.11

Posted

can I still download a version of firefox for Mac OS 10.4.11

can I still download a version of firefox for Mac OS 10.4.11

Chosen solution

Firefox 4 versions and later do not run on a PowerPC Mac.
Firefox 4 and later require at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 7 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here:

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Netscape Navigator Default Plug-in
  • Octoshape Streaming Services Web Integration Browser Plug-In. Octoshape
  • Mit dem QuickTime Plug-in können Sie eine Vielzahl von Multimedia-Inhalten auf Webseiten anzeigen. Für weitere Informationen besuchen Sie die QuickTime WWW-Seite.
  • Java 1.3.1 Plug-in
  • Java 1.3.1 Plug-in (CFM)
  • Shockwave Flash 7.0 r24
  • Macromedia Shockwave for Director Netscape plug-in, version 10.1.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; de; rv:1.9.0.19) Gecko/2011091218 Camino/2.0.9 (MultiLang) (like Firefox/3.0.19)

More Information

ideato
  • Top 25 Contributor
756 solutions 5467 answers

Helpful Reply

3.6.16

download from here, all languages:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.6.16/mac/


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

3.6.16 download from here, all languages: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.6.16/mac/ thank you Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.
cor-el
  • Top 10 Contributor
  • Moderator
12744 solutions 117102 answers

Chosen Solution

Firefox 4 versions and later do not run on a PowerPC Mac.
Firefox 4 and later require at least OS X 10.5 and an Intel Mac.

For an unofficial Firefox 7 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

Firefox 3.6.x (Mac OS X 10.4 and later) can be found here:

Firefox 4 versions and later do not run on a PowerPC Mac.<br /> Firefox 4 and later require at least OS X 10.5 and an Intel Mac. * http://www.mozilla.com/firefox/6.0/system-requirements/ For an unofficial Firefox 7 compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at: * http://www.floodgap.com/software/tenfourfox/ * http://www.macupdate.com/app/mac/37761/tenfourfox Firefox 3.6.x (Mac OS X 10.4 and later) can be found here: * http://www.mozilla.com/en-US/firefox/all-older.html