On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with JuniperSetupClientInstaller. Does not run, only save option

  • No replies
  • 66 have this problem
  • 10 views
more options

Firefox is a optional application used in our organization. There about 2000 Firefox users. We have VPN portal running from web interface, which uses Juniper Client to connect intranet. Until Firefox version 6 it was working ok. Since Firefox 7, whenever we launch the portal, instead of running the add-on JuniperSetupClientInstaller.exe automatically, it asks to save file. I save it, run it and relaunch the Firefox and go to the portal. And I get the same "Save" prompt. The site requires Java and this plugin. Java is installed but I can not get this plugin work. It works fine with IE and it works in Firefox with "IE tab 2(3.5.9.1)" enabled for this site, which is pretty much the same IE running on the background

Firefox is a optional application used in our organization. There about 2000 Firefox users. We have VPN portal running from web interface, which uses Juniper Client to connect intranet. Until Firefox version 6 it was working ok. Since Firefox 7, whenever we launch the portal, instead of running the add-on JuniperSetupClientInstaller.exe automatically, it asks to save file. I save it, run it and relaunch the Firefox and go to the portal. And I get the same "Save" prompt. The site requires Java and this plugin. Java is installed but I can not get this plugin work. It works fine with IE and it works in Firefox with "IE tab 2(3.5.9.1)" enabled for this site, which is pretty much the same IE running on the background