Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm using an older iMac with OS10.4.11, and I'm using Firefox 3.6.17. The newest version of Firefox doesn't work with my computer. I've tried to find a download for Firefox 3.6.22 but can't find it. What can I do, I can't afford to upgrade my computer?

  • 2 replies
  • 16 have this problem
  • 47 views
  • Last reply by James

more options

Help! I would like to update to the highest version I can with my older system - Mac OS 10.4.11. Can you help me?

Chosen solution

All Replies (2)

more options

Chosen Solution

more options

As you have a Power Mac you also have a alternative option to consider which is a third-party build from http://tenfourfox.blogspot.com/2011/08/601-now-available.html