Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Closing Firefox doesn't sign me off Gmail, contrary to Firefox 3.

  • 6 replies
  • 31 have this problem
  • 14 views
  • Last reply by psoa

more options

I'm a new user of Firefox 6. I use Gmail and would like to sign off when I close Firefox, which was the default behavior in Firefox 3. Now I'm still sign in when I open Firefox, which means that anybody can see my emails if I forgot to explicitely sign off from Gmail before closing Firefox (or switching off my desktop for that matter).

I'm a new user of Firefox 6. I use Gmail and would like to sign off when I close Firefox, which was the default behavior in Firefox 3. Now I'm still sign in when I open Firefox, which means that anybody can see my emails if I forgot to explicitely sign off from Gmail before closing Firefox (or switching off my desktop for that matter).

Chosen solution

You can set the pref browser.sessionstore.privacy_level to 2 (never) or 1 (non-HTTPS, default in Firefox 3 versions) on the about:config page to disable saving cookies via session restore.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold (user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
Read this answer in context 👍 9

All Replies (6)

more options
  1. Open gmail
  2. Click "Sign out"
  3. Log on again, but make sure "Remember Me" (or "Keep me logged in") is not checked.

Modified by m-wynn

more options

Remember me was already unchecked. This doesn't change anything.

more options

There's probably a permanent log-in cookie somewhere in your system. Try Clearing your cache and cookies.

more options

Done that, thanks for the suggestion ! Not solving the problem however.

Assuming you've got a Gmail Account, do you have the same behavior on your browser ? Or not ?

Thanks.

more options

Chosen Solution

You can set the pref browser.sessionstore.privacy_level to 2 (never) or 1 (non-HTTPS, default in Firefox 3 versions) on the about:config page to disable saving cookies via session restore.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold (user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
more options

Wow: it works !! Thanks very much cor-el !! Second time you give me a solution :o) much appreciated.