X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why has search suddenly started to default to Ask instead of Google and how do I change it back?

Posted

I'm used to typing search terms in the middle box on the toolbar (the one with the "bookmark" star) and automatically getting to a list generated by Google. Now it's suddenly defaulted to Ask with no reason. Ask is awful. How do I change it back? I've removed Ask from the 'manage search engines' tab in the top right box so I can use that box instead but that's not the way I'm used to doing things and it's changed with no intervention from me! Thanks!

Additional System Details

This happened

Every time Firefox opened

This started when...

Today 16 September

Installed Plug-ins

  • np-mswmp
  • The BT Broadband Support Tools is part of the BT's Getting Setup Portal,as it provides additional help wizards for your BT Total Broadband product.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Provides additional functionality on Facebook. See our web site for details.
  • npybrowserplus_2.4.21
  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • SiteAdvisor
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Motive Plugin for Mozilla Browsers
  • 6.0.12.1483
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Unity Player 2.5.0f5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

Hasan 477 solutions 5600 answers

-> Search Bar - Removing a Search Engine

-> Restore Default Search Engine (Google)

Type about:config in the Location (address) bar and press the "Enter" key. When you see a warning, click I'll be careful, I promise! button.

  • Preferences that have been modified are shown as bold (user set).
  • Preferences can be Reset to the default or changed via the right-click context menu.

-> In the Filter bar, type browser.search.selectedEngine

  • right-click the preference browser.search.selectedEngine and choose Reset from the menu.

-> In the Filter bar, type ask.com. This will show the remaining ask.com related preferences.

  • right-click all ask.com related Preferences (one by one) and choose Reset from the menu to restore their Default values.

-> Close the about:config tab and then Restart Firefox.

Check and tell if its working.

Modified by Hasan

Question owner

Thanks for quick response. I got stuck at the second bullet - the 'reset' is greyed and won't let me select it. It's currently set as 'default'.

Hasan 477 solutions 5600 answers

Close all Firefox Tabs & Windows except about:config tab.

Question owner

Nope, still grey.

Hasan 477 solutions 5600 answers

-> Close Firefox (click Firefox button and click Exit OR File Menu -> Exit)

-> Start Firefox in Safe Mode by holding down SHIFT key while starting Firefox

  • As an alternative method, use Win + R key combination and enter one of the following in the Windows Run box:
    • firefox -safe-mode
    • "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode

-> Firefox Safe Mode window will appear -> DON'T SELECT ANY OPTIONS, just click Continue in Safe Mode

Now perform the steps mentioned in my first reply. Check and tell if its working.

Modified by Hasan

Question owner

Hi again. It still doesn't work. Here's a screen dump - a bit small but you can see it's still greyed even in safe mode. Sorry...

Hasan 477 solutions 5600 answers

You are trying to Reset services.sync.prefs.sync.browser.search.selectedEngine. That preference is correct. You are looking for the wrong preference.

You have to Reset browser.search.selectedEngine (the selected Blue preference - attached screenshot)

After this, Continue forward using my first reply. Check and tell if its working.

Question owner

When I type browser.search.selectedEngine into the filter bar it only comes up with the services.sync.prefs.sync.browser.search.selectedEngine only, nothing else, per my screenshot sent earlier. There's no other options to select when it filters, just that one comes up.

Hasan 477 solutions 5600 answers

Does it still not appear when you start Firefox in Safe Mode ??

Modified by Hasan

Question owner

Nope, 'fraid not.

Hasan 477 solutions 5600 answers

Proceed to the next step mentioned in my first reply.

Check and tell if its working.

Modified by Hasan

Question owner

You bet. Thanks so much for all your help and patience. I hate computers (but I couldn't live without them!). Have a good day/weekend.

Hasan 477 solutions 5600 answers

IF it still won't work after performing the lateral steps mentioned in my first reply, Create a New Profile as a test to check if your current profile is causing the problems.

-> Basic Troubleshooting: Make a New Profile

IF that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile.

-> Recovering important data from an old profile

Check and tell if it works.

Modified by Hasan

Question owner

Obviously UK English and US English aren't the same! It's working now, I just reset the ask.com preferences in the about:config bar without going via browser.search.selectedEngine. Thanks again for everything.

Hasan 477 solutions 5600 answers

To help other users find solutions, please return to this Thread and Sign-in to the forum with your Username and Password:

click on "Solved It" Next to the reply ABOVE that BEST solved your Question

DO NOT click "Solved It" next to this reply