X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I change the default startup mode to 32-bit mode

Posted

This is the message I receive when I try to download my music order from musicnotes.com: Sorry, this plugin requires that your browser run in 32-bit mode. To change the default startup mode of Firefox to 32-bit, click on the screen and select the menu item: "Show me the 'Application Info' window so I can set 32-bit mode myself" I don't know what screen they are referring to. How do I change the default startup mode to 32-bit? Leanne Norman

Chosen solution

  1. Close Firefox
  2. Start the Finder and open the Applications folder
  3. Right click or control-click the Firefox.app icon
  4. Select "Get Info"
  5. Select or Deselect "Open in 32-bit mode"
  6. Close the "Firefox Info" window
  7. Restart Firefox
Read this answer in context 14

Additional System Details

Installed Plug-ins

  • Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com
  • iPhoto6
  • Shockwave Flash 10.1 r102
  • Musicnotes Viewer plugin 1.19.0 http://www.musicnotes.com
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Chosen Solution

  1. Close Firefox
  2. Start the Finder and open the Applications folder
  3. Right click or control-click the Firefox.app icon
  4. Select "Get Info"
  5. Select or Deselect "Open in 32-bit mode"
  6. Close the "Firefox Info" window
  7. Restart Firefox

Question owner

Thanks to the contributors to Firefox who helped me solve my "32-bit mode" problem. All is well on the Norman computer.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You're welcome

dchesnick 0 solutions 1 answers

Wait... I have this problem as well but when I open "Get Info" I don't have an open in 32 bit option. Weird. I'm running leopard and Firefox 6.0.2

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Do you have a system with a 32 bit processor or are in some 32 bit compatibility mode?

rahardy100 0 solutions 4 answers

What and where is the "Finder"?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Helpful Reply

See http://en.wikipedia.org/wiki/Macintosh_Finder

rahardy100 0 solutions 4 answers

I see, it only applies to an Apple computer, while I have a PC. No wonder I can't find it. Do you have a solution for a PC with Windows 7?

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Official Firefox versions from the Mozilla site that run on a PC are still 32 bit versions and shouldn't require extra measures apart from having 32 versions of all plugins.
On Mac Firefox comes as a i386/x86_64 universal binary and the default is running in 64 bit mode. If you have a plugin on Mac that only has a 32 version then you need to start Firefox on that Mac in 32 bit mode.


Are you running Firefox on a 64 bit version of Windows 7?

Which plugin is causing problems?

racha 0 solutions 2 answers

I have a 64 bit version of windows which I run mozilla with. I am not able to get the java to load on a website i need to scan deposits. The faq's said I'd need to be in 32-bit java mode. I was hoping this was the problem, but I can't seem to find a way to change to 32-bit.

Modified by racha

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You need a 32 bit Java plugin to work with a 32 bit Firefox version.

racha 0 solutions 2 answers

Thanks so much for your input. However, I went to the oracle website, I read the installation instructions for the JRE install of of SRE 7 ( http://docs.oracle.com/javase/7/docs/webnotes/install/windows/jre-installation-windows.html ) specifically the bottom portion "Installation of JRE on 64-Bit Windows Computers". It makes it seem like there are options for downloading 64 bit or 32 bit installer versions, however I CANT FIND THEM =(. I went ahead and downloaded the Jave Sre 7 u2 JRE , windows x86 online, hoping this was right.

Java still wouldn't load on the website I needed. So I tried using Internet Explorer instead, poof it worked. Still not sure why, I did have to authorize some sort of popup that never popped up when trying to use Mozilla, but it worked so that's all I care about.

Thanks again.

frjgwils 0 solutions 1 answers

I didn't need the Java or JRE. I just closed Firefox, went to the applications folder, clicked on the 32 bit mode, opened Firefox again and voila! Works on my Mac OSX 10.6.8!

carlc 0 solutions 1 answers

I have MAC OS 10.5.8 and Firefox 11.0 version running, i do not see the check box with as indicated in step 5. Select or Deselect "Open in 32-bit mode". I have tried install various FF version 12, 3.6.x, but no luck.

Is this related to MAC OS version or Any idea how to get the check box to show up to launch Firefox with 32bit ?