X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Google links to Ad Sites and unrequested audio plays in background

Posted

1) When I click on links from Google searches it redirects to Ad websites...

2) When I have Internet windows open suddenly audio (that sounds like it is coming from other unopened websites) will start playing.

Additional System Details

This happened

Every time Firefox opened

This started when...

In the last week

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.22) Gecko/20110902 Firefox/3.6.22 GTB7.1 ( .NET CLR 3.5.30729)

More Information

Not sure what you need here

David McRitchie 321 solutions 3089 answers

If it's an ad site on Google, it would probably be blocked the "Adblock Plus" with the right subscription filters, or a filter you make.

See http://kb.mozillazine.org/Blocking_bad_sites_and_annoyances

the links for extensions are near the bottom of the page

That will probably stop your problem there are other things you can try:

"Stop Autoplay" extension (I have it disabled, think it would not show the first frame)


media.autoplay.enabled   user set   boolean   False (have that, shows up in about:config but not in about:support)

nothing for stopping autoplay in these

http://kb.mozillazine.org/Flash
http://kb.mozillazine.org/Blocking_bad_sites_and_annoyances


see Load Tabs Progressively, Load tabs one by one.  Limit the number of concurrent loading tabs and/or unread loaded tabs. (too restrictive for me)

I would certainly take a look at, the second link requires Stylish extension.


Please mark "Solved" one answer that will best help others with a similar problem -- hope this was it.

Modified by David McRitchie

Julysuu 0 solutions 10 answers

1.To stop all JS.Twettir processes, press CTRL+ALT+DELETE to open the Windows Task Manager.

2.Click on the "Processes" tab, search for JS.Twettir, then right-click it and select "End Process" key.

3.Delete Temporary Internet files,Cookies,Cache & History of all the browsers present in your system.

4.Check the internet settings of your browser for any unwanted Proxy settings.If it is there then remove it & set it to 'Automatically Detect Settings'.It might be as below - IP Address - 127.0.0.1 Port No - 80

5.Check if unnecessary DNS IP's are present in 'Local Area Connection Properties'. 6.Open command prompt & run the below commands - ipconfig /flushdns.

Reference: http://blog.teesupport.com/best-way-to-fix-google-search-results-being-redirected-virus-in-firefox/

Modified by Julysuu