Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I have a drop down coupon box that keeps dropping down and i need to know how to remove it


this box drops down constantly and i do not use or want it how do i remove it and keep it from coming back

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • Garmin Communicator Plug-In
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • SiteAdvisor
  • 4.0.60531.0
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update


  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

unique4u88 0 solutions 1 answers

Its an Yontoo ad that installed itself on your computer. Go to the control panel on your computer and uninstall it

Question owner


karasita 0 solutions 1 answers

I had the same problem. I found a coupon app in a program called "Get It Free". After checking in the control panel, I selected "remove program" and found it. I was then able to delete the app.

desiree7790 0 solutions 1 answers

Helpful Reply

I found it in add/remove programs : "I WANT THIS" I deleted it and works fine, Hope works for you .

gggcc 2 solutions 11 answers

You have to kill it in two places. FF must be generating revenue from this.

Goto Add-ons

1) Click on the Plug Ins tab.

   Disable both "Coupon Inc" addons.  For some reason I had two.

2) Click on the Extensions tab

   Disable the "Start Now toolbar"

What a pain.