X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I move my bookmarks from the menu bar to the bookmarks toolbar?

Posted

After I upgraded my firefox to version 6, all my bookmarks that were previously in my bookmark toolbar are now in the menu bar, and the bookmark toolbar just shows up with no buttons. How do I move the bookmarks back to their own bar? I'd like to hide the menu bar.

Thanks.

Chosen solution

Check that the Bookmarks Toolbar is visible and that the "Bookmarks Toolbar items" is still placed on the Bookmarks Toolbar.
If the menu bar is hidden then press F10 or hold down the Alt key, that should make the "Menu Bar" appear.

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible: "View > Toolbars"

  • Open the Customize window via "View > Toolbars > Customize" or via "Firefox > Options > Toolbar Layout" and check that the "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • If the "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette in the customize window to the Bookmarks Toolbar
  • If you do not see the "Bookmarks Toolbar items" or other items that are missing in the toolbar palette or on a toolbar then click the "Restore Default Set" button

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • PDF-XChange Viewer Netscape Gecko Plugin
  • Office Plugin for Netscape Navigator
  • Winamp Application Detector
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Google Update
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

Question owner

Thanks but I didn't see the topic on that page apply to my problem. The bookmarks are already in the bookmark toolbar folder.

Here's a screenshot of what I see. The bookmarks are part of the menu bar, and the bookmark toolbar (below the address bar) is empty.

Modified by fishpup

Hasan 477 solutions 5600 answers

I find it more convenient to use the Bookmarks drop-down menu button in the Customize Toolbar window instead of the Bookmarks Toolbar.

-> There are 2 Bookmarks * buttons in the Customize Toolbar window

  • 1 Bookmarks * button opens the Bookmarks Sidebar
  • 1 Bookmarks * button open a Bookmarks Drop-down Menu

-> Use the Bookmarks drop-down menu button.

-> Now Open the Bookmarks Library using CTRL + SHIFT + B shortkeys

-> After you are done arranging your Bookmarks, Remove the Bookmarks Toolbar & Items button from the Navigation Toolbar

Check and tell if its working.

Modified by Hasan

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Chosen Solution

Check that the Bookmarks Toolbar is visible and that the "Bookmarks Toolbar items" is still placed on the Bookmarks Toolbar.
If the menu bar is hidden then press F10 or hold down the Alt key, that should make the "Menu Bar" appear.

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible: "View > Toolbars"

  • Open the Customize window via "View > Toolbars > Customize" or via "Firefox > Options > Toolbar Layout" and check that the "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • If the "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette in the customize window to the Bookmarks Toolbar
  • If you do not see the "Bookmarks Toolbar items" or other items that are missing in the toolbar palette or on a toolbar then click the "Restore Default Set" button

Question owner

The Restore Default Set solved my problem! Thank you!

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You're welcome