X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

What version of Firefox am I running...?

Posted

Firefox says I'm running the latest browser version, yet when I try to fill out a FAFSA application (at fafsa.ed.gov), I am directed to a page with the following message: "An Incompatible Browser Has Been Detected: Your Web browser is not supported by our Web site. You must use a Compliant Web Browser - Standard* to view our site properly. We recommend you upgrade to the latest version of your browser according to your Operating System."

I can't find an older version to download. Please link to a page with the proper version. The page recommends Firefox 3.5x or 3.6x for Windows 7.

Additional System Details

Sites Affected

https://fafsa.ed.gov/FAFSA/app/errors?page=incompatibleBrowser

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.9
  • Version 2.2.2.0
  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npmnqmp 989898989877
  • Google Update
  • Shockwave Flash 10.2 r153
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24448 answers

Install Firefox Portable 3.6.21 to your hard drive to use at the FAFSA website.
http://portableapps.com/apps/internet/firefox_portable/localization#legacy36

paulapoka 0 solutions 1 answers

log into old apps, there you can access any old version