Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox did an automatic update to 6.01, and now my middle mouse button is not working in the browser. It doesn't close tabs, it doesn't open new tabs by middle clicking a link, it doesn't allow me to middle click to scroll the page...

  • 13 replies
  • 205 have this problem
  • Last reply by Taarruz

more options

Firefox did an automatic update to 6.01, and now my middle mouse button is not working in the browser. It doesn't close tabs, it doesn't open new tabs by middle clicking a link, it doesn't allow me to middle click to scroll the page..

All Replies (13)

more options

I have this problem too, I can't even press it down any more let alone use it to open new tabs etc. I use a logitech wireless mx5500 revolution desktop if that helps.

more options

I've disabled csfire_1.0.1 addon and after that it's working. (For me at least) Try safe mode without addons enabled.

more options

Try the Firefox SafeMode to see how it works there.
A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  • You can open the Firefox 4/5/6/7 SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

Don't select anything right now, just use "Continue in SafeMode."

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.

more options

This is my first post, so please forgive any mistakes. I used to have this problem, as well, and at least in my case, it turned out to be unrelated to Firefox, even though it did coincide with the 6.0.1 stable release.

One thing I noticed is that my Windows key shortcuts (ie. Windows key + R to bring up the "run" dialog) stopped working, but the key binding for the windows key itself was still intact (ie. hitting the windows key on Win 7 Pro would still bring up the start menu but none of the shortcut would work).

What did do the trick for me was re-installing the keyboard driver, even though the device manager did not show any conflicts. Hope this helps. :)

Edit: Oh, and running FF with add-ons disabled and with a fresh profile did not resolve the issue for me (which you'd expect since the problem wasn't related to FF, in my case).

Modified by last

more options

My Middle Mouse button/wheel works on every thing but opening links in new tabs.

-What works- Opening rss links in new tabs Opening bookmarks in new tabs Opening a closed tab by clicking the middle button/wheel in the tab area Closing a tab

-What doesn't work- Opening a link on a web page in a new tab

I tried opening firefox in safemode and it does work but when I opened it again in normal mode and disabled all of the add-ons it doesn't work. Now, I updated it last night and while it worked before the update now it doesn't. Please help

more options

Mine is working again and for me, seems to be related to the foxtabs addon once I removed it it has been working fine.

more options

Starting in safe mode, then switching back to normal seems to have resolved the issue for me.

Restarting in safe mode, things were fine, then stayed fine as I tried each add-on afterwards. I'm now running with both add-ons enabled (https-everywhere 1.0.1 and Adblock plus 1.3.9 on mac 10.6.8), and things are back to normal.

more options

[BUG FIXED, see "EDIT 2" at the end of my post]

I'm on Firefox 3.6.21, and I got this problem today after a Greasemonkey update (To version 0.9.10, apparently).

Disabling Greasemonkey solved the problem, and re-enabling it reproduced the problem (middle-clicking links to open in new tab did not work, merely highlighted the link).

I should also note that while Greasemonkey was enabled and the bug was affecting me, Ctrl+Click to open links in new tabs was also broken.

I hope this helps!

EDIT: It appears this is a known incompatibility/conflict bug between current versions of Greasemonkey and Tab Mix Plus. Read more here:

EDIT 2: GREASEMONKEY HAS NOW BEEN UPDATED with a workaround to fix the problem. Go to to install the update manually. It hasn't been reviewed by Mozilla yet, so it won't be an automatic update for another day or two. All credit to "cannonfodder" below for noticing this; please mark his post as helpful!

Modified by AvohkahTamer

more options

Thanks for the help "the-edmeister". My issue was that the automatic update rendered my mouse unable to middle-click to open a link in a new tab. With your directions I discovered that if I disabled the GREASEMONKEY extension, my mouse's middle-click capabilities were restored. Thanks.

Modified by keith0718

more options

@keith0718: My problem was Greasemonkey too. I disabled it, restarted, and the middle-click worked again. Thanks for the tip.

more options

Double-post. Sorry.

Modified by cbhall

more options

Just install version 0.9.11 of greasemonkey here:

No need to disable it.

more options

Yeah greasemonkey makes problem. i had same problem i couldnt click with middle mouse on links and couldnt open new tab. i disabled greasmonkey its solved. im using firefox 6.0.1.

Modified by Taarruz