Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why does avg search come up when I enter anything on my firefox home page it's driving me nuts

  • 6 replies
  • 119 have this problem
  • 2165 views
  • Last reply by hollyhock

more options

I removed avg free from my computer because avg was "taking over" my searches - but it is still doing it. I can't seem to get rid of it even though I have tried to follow all the suggestions on mozilla support pages - I don't want to change search engines, as I really like Firefox. Please tell me how to get rid of avg in a SIMPLE to understand way. Many thanks.

All Replies (6)

more options

AVG's toolbar is still an opt-out feature. It also will commandeer your default search engine for Yahoo, so if you don't want it to do that, you'll want to uncheck the box that changes your search engine, too. Source: CNet Editor's review

If the search when using the Location/URL bar has been taken over by Yahoo (AVG's default search -- see above), you may need to reset a preference:

  1. Enter about:config in the address/URL bar and press the Enter key
  2. f you see a warning, accept it (Promise that you will be careful)
  3. Filter = keyword.url
  4. Below the Filter, right-click on keyword.URL and choose "Reset"
  5. Restart Firefox (File > Restart Firefox)
  6. See:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

Thanks for that - but I've tried that, and I changed avg save search to google, and it still comes up with avg safe search. If I type something into the firefox box and press enter, it goes to a really "boring" looking page with avg in blue letters on the top of the page on the left hand side followed by "sites checked by avg", then there is a box with the question that I asked, saying powered by google,then a list of different languages, and then a list of possible answers relating to my question, all in blue print on a plain white page, totally uninspiring. I can't get rid of it. I hope you can understand all this, as I really don't know the technical terms to describe it. If you can suggest something else I would appreciate it ( I also restored my computer to a previous date). Thanks.

more options

Now that you explain in more detail, that is what AVG Safe Search does. From my limited knowledge of the product, it searches and presents a list of websites that AVG has found to be "safe". Most users posting here are complaining their search engine has been changed to Yahoo by AVG Safe Search; Yahoo is the default search engine for AVG Safe Search.

AVG forums: http://forums.avg.com/us-en/avg-free-forum

If you want to remove AVG Safe Search: http://www.ehow.co.uk/how_8237718_remove-avg-safe-search-firefox.html

If you remove AVG Safe Search and your searches from the Location/URL bar do not return to using Google, use the 6 step about:config instructions in my first post.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modified by SafeBrowser

more options

Thank you for your help. I did what you suggested, but when I went into Tools, Add-ons, then Extensions, AVG Safe Search wasn't there. The only thing relating to it was this "Change Default Search Engine 1.ob"; so I disabled it, then restarted Firefox, and AVG was still there. So I did the six step About:config process, (which I have now done endlessly), and that didn't work either. What happens when I type something into the Location/URL search bar is that avg takes over, then it passes the info on to google, and I then get google's search bar in the middle of my firefox home page - where the firefox search bar was, so it's quite a "long" process, and if I type something into the Firefox homepage search bar, as I used to, I just get the avg safe search list. Do you think you can help? If you can that it would be great as it's doing my head in...

more options

Since your problem appears to be with whichever of the several AVG products you have installed, I suggest the you post on the AVG forum and ask how to disable the AVG search function:

Any problem with a 3rd-party application that installs toolbars or other functions that affect Firefox, should always be first addressed to the 3rd-party developer.

So that other users might be able to find an answer when experiencing a similar problem with AVG, please post back in a reply here with a link to any solution that you might get in the AVG forum. Thanks.

more options

Thank you for your suggestion. I went onto the avg site, but somehow it put my email address as the user name, even though I entered a different user name - so I decided not to pursue it. Anyway, to cut a long story short - I just entered a question on google search saying "how to change my homepage to google", and managed to do it, finally! Click on Tools, then Options, then click General, then where it says Startup, the second line under it says Homepage, delete www. Firefox from the box, and enter www.google.com (or whatever search engine you want), and then click Ok and it's done! So thank's very much.