X
Tap here to go to the mobile version of the site.

Support Forum

Blurry flash fonts under Firefox 6

Posted

I have problem accessing a streaming website ( http://www.hkadr.com/stream.php ) that shows flash fonts. OK no problem with FF5, Chrome, IE.

For FF6, it is OK if I disable Aero Theme (transparent mode). Or, it is OK also if I turn the monitor resolution to 16 bit high color (from the default setting of 32 bit true color)

I have tried: disabling hardware acceleration, reset Cleartype text, upgrading the graphic card driver to the latest version - all cannot help FF6 read the problematic flash font website clearly.

My system is Win7 64 bit, AMD 6670 graphic card, CPU Q9550S, and I am running 2 monitors of 1920x1080 under 32 bit true color.

I read from another help thread that FF7 may have solved this, but I still cannot read the website under FF7.

Anyone can help please ?

I have problem accessing a streaming website ( http://www.hkadr.com/stream.php ) that shows flash fonts. OK no problem with FF5, Chrome, IE. For FF6, it is OK if I disable Aero Theme (transparent mode). Or, it is OK also if I turn the monitor resolution to 16 bit high color (from the default setting of 32 bit true color) I have tried: disabling hardware acceleration, reset Cleartype text, upgrading the graphic card driver to the latest version - all cannot help FF6 read the problematic flash font website clearly. My system is Win7 64 bit, AMD 6670 graphic card, CPU Q9550S, and I am running 2 monitors of 1920x1080 under 32 bit true color. I read from another help thread that FF7 may have solved this, but I still cannot read the website under FF7. Anyone can help please ?

Modified by huibtk

Additional System Details

Sites Affected

http://www.hkadr.com/stream.php

Installed Plug-ins

  • Shockwave Flash 11.0 d1
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • 4.0.60531.0
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158614 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot Use a compressed image type like PNG or JPG to save the screenshot and make sure that you do not exceed the maximum file size (1 MB).

Question owner

Hello Cor-el; here is the screenshot.

No problem in reading the page if I use FF5/Chrome/IE or if I disable Aero Theme or if I use 16 bit color (instead of 32 bit).

PS: also attached is a screenshot from FF5 which shows no problem

Thanks for your help.

Hello Cor-el; here is the screenshot. No problem in reading the page if I use FF5/Chrome/IE or if I disable Aero Theme or if I use 16 bit color (instead of 32 bit). PS: also attached is a screenshot from FF5 which shows no problem Thanks for your help.

Modified by huibtk

Hasan 469 solutions 5600 answers

Then use some other Theme and Remove/Disable the Aero Theme

Troubleshooting extensions and themes

Check and tell if its working. IF the problem is only with Aero theme, tell the Aero Theme Developers about this issue. They might tell you that they will look into this Bug and plan on releasing an Updated version to fix this issue.

Then use some other Theme and Remove/Disable the Aero Theme Troubleshooting extensions and themes * https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Check and tell if its working. IF the problem is only with Aero theme, tell the '''Aero Theme Developers''' about this issue. They might tell you that they will look into this Bug and plan on releasing an Updated version to fix this issue.

Modified by Hasan

Question owner

Hmmm... Disabling Aero theme is not a preferable option.

I am now using FF5 instead. But it is saddening that Firefox 6+ cannot support my viewing on this streaming flash font website while everything else can.

Hmmm... Disabling Aero theme is not a preferable option. I am now using FF5 instead. But it is saddening that Firefox 6+ cannot support my viewing on this streaming flash font website while everything else can.
Hasan 469 solutions 5600 answers

IF the problem is due to using Aero Theme, then its the FAULT of the Aero Theme Developers for not releasing a Compatible version to be used with Firefox 6.0.

Firefox Developers Team always Notifies the Add-on Developers about their plans for releasing a New Version many months before the actual release. So its upto the Add-on Developers if they wish to Update their Code in order to be Compatible with the New Firefox versions.

IF the problem is due to using Aero Theme, then its the FAULT of the Aero Theme Developers for not releasing a Compatible version to be used with Firefox 6.0. Firefox Developers Team always Notifies the Add-on Developers about their plans for releasing a New Version many months before the actual release. So its upto the Add-on Developers if they wish to Update their Code in order to be Compatible with the New Firefox versions.

Question owner

Well... I disagree. Aero theme occupies resources, so disabling it means freeing up resources for other applications like FF6. But Aero theme has been here for many years - everyone knows about its benefits and short comings.

To me, it is the in-capabilities of FF6 to manage graphic resources so that it cannot show the flash fonts properly because it cannot manage resources well under Aero theme, so while all others, including FF5, can do no problems.

Can we not finger-point at Aero, Adobe Flash, or Firefox ? If Firefox team says OK this is just a minor casualty for the bigger brighter future things to come, then OK it is fine. I can always choose FF5 or other browsers.

Well... I disagree. Aero theme occupies resources, so disabling it means freeing up resources for other applications like FF6. But Aero theme has been here for many years - everyone knows about its benefits and short comings. To me, it is the in-capabilities of FF6 to manage graphic resources so that it cannot show the flash fonts properly because it cannot manage resources well under Aero theme, so while all others, including FF5, can do no problems. Can we not finger-point at Aero, Adobe Flash, or Firefox ? If Firefox team says OK this is just a minor casualty for the bigger brighter future things to come, then OK it is fine. I can always choose FF5 or other browsers.
Hasan 469 solutions 5600 answers
Fonts look blurry * https://support.mozilla.com/en-US/kb/fonts-look-blurry Managing the Flash plugin * https://support.mozilla.com/en-US/kb/Managing%20the%20Flash%20plugin Troubleshooting plugins * https://support.mozilla.com/en-US/kb/Troubleshooting%20plugins Check and tell if its working.

Question owner

Have tried them all but none works. So back to Firefox 5 now..

Have tried them all but none works. So back to Firefox 5 now..
Hasan 469 solutions 5600 answers

-> click Firefox button and click Options > Advanced panel > General tab > Remove Checkmark from Use Hardware Acceleration when available

  • If Disabling hardware acceleration works then check if there is an update available for your graphics display driver.

Update All your Firefox Plugins

Check and tell if its working.

-> click '''Firefox''' button and click '''Options''' > Advanced panel > General tab > Remove Checkmark from '''Use Hardware Acceleration when available''' * If Disabling hardware acceleration works then check if there is an update available for your graphics display driver. Update All your Firefox Plugins * https://www-trunk.stage.mozilla.com/en-US/plugincheck/ * http://www.mozilla.com/en-US/plugincheck/ Check and tell if its working.

Question owner

"...I have tried: disabling hardware acceleration, reset Cleartype text, upgrading the graphic card driver to the latest version - all cannot help FF6 read the problematic flash font website clearly..."

All tried none worked >_<

"...I have tried: disabling hardware acceleration, reset Cleartype text, upgrading the graphic card driver to the latest version - all cannot help FF6 read the problematic flash font website clearly..." All tried none worked >_<
Hasan 469 solutions 5600 answers

-> Try to disable "Morphological Filtering" in the Catalyst display driver

  • Catalyst Control Center > 3D Settings > Disable Morphological Filtering

Check and tell if its working.

-> Try to disable "Morphological Filtering" in the Catalyst display driver * Catalyst Control Center > 3D Settings > Disable Morphological Filtering Check and tell if its working.
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158614 answers

Try to toggle some Boolean gfx.font_rendering prefs on the about:config page to disable some features and maybe set gfx.direct2d.disabled -> true to disable Direct2D.
Filter: gfx

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
Try to toggle some <u>Boolean</u> gfx.font_rendering prefs on the about:config page to disable some features and maybe set gfx.direct2d.disabled -> true to disable Direct2D.<br /> Filter: gfx To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br /> *Use the Filter bar at to top of the about:config page to locate a preference more easily. *Preferences that have been modified show as bold(user set). *Preferences can be reset to the default or changed via the right-click context menu.

Question owner

Everything is alright now !!!!!!!!!

I changed my soundcard from an Asus Xonar Essence to an Onkyo one. With it, I run both FF7 and FF8 and can read the flash fonts from HKADR.com no problem.

My Windows Experience Index was CPU: 7.3, and Graphic was 6.9 when I had the Asus soundcard and could not read HKADR flash fonts. Now, with Onkyo soundcard, CPU: 7.3, and Graphic: 7.1. So, the change of soundcard frees up resources for graphic to run flash fonts.

Thanks for your help & attention ^_^.

Everything is alright now !!!!!!!!! I changed my soundcard from an Asus Xonar Essence to an Onkyo one. With it, I run both FF7 and FF8 and can read the flash fonts from HKADR.com no problem. My Windows Experience Index was CPU: 7.3, and Graphic was 6.9 when I had the Asus soundcard and could not read HKADR flash fonts. Now, with Onkyo soundcard, CPU: 7.3, and Graphic: 7.1. So, the change of soundcard frees up resources for graphic to run flash fonts. Thanks for your help & attention ^_^.
Hasan 469 solutions 5600 answers

To help other users find solutions, please return to this Thread and Sign-in to the forum with your Username and Password:

click on "Solved It" Next to the reply ABOVE that BEST solved your Question

DO NOT click "Solved It" next to this reply

To help other users find solutions, please return to this Thread and '''Sign-in''' to the forum with your Username and Password: click on '''"Solved It"''' Next to the reply ABOVE that '''BEST''' solved your Question '''DO NOT click "Solved It" next to this reply