Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

problem with netflix after upgrading to firefox 6

  • 7 replies
  • 149 have this problem
  • 338 views
  • Last reply by Joelius

more options

now that I have upgraded to firefox 6 I can't instant watch netflix anymore. please help I'd rather not have to use a different browser to do this.

Chosen solution

This also works if you are having trouble with the Mozilla FireFox 10.0 upgrade if you disguise it as 9.0.1 according to DavidLee1951's instructions. Thanks David Lee!

Read this answer in context 👍 0

All Replies (7)

more options

Figured it out today. You have to find your executable program in the Mozilla folder and right click on it and choose properties. In the properties choose the compatibility tab and check the box " run this program in compatibility mode for" Then choose Windows XP.

Did this and my netflix is not running on the Beta 7 version of Firefox.

more options

Sorry I mean't is now running on the Beta7 version of firefox

more options

SOLUTION

The problem with Netflix streaming with the FireFox 6.0 version is that the Netflix service refuses version 6.0 because they are A) unwilling to license it or B) too lazy or stupid to add the new version to their User Agent acceptance scheme. C) under contract to MICROSOFT to use Silverlight and part of Silverlight's DRM is what Browser versions are acceptable and Microsoft is taking their sweet time updating Silverlight to push I.E. on people and if you have Beta 5 Silverlight forget that -------Until Netflix accepts Firefox 6.0 as a legitimate Netflix browser you may do what I have done to get Firefox 6.0 streaming at Netflix.

1) Open Firefox 6.0 and enter "www.whatsmyua.com" without quotations in the address bar and highlight and copy your present User Agent string from the top of that page when you get there.

2) Type "ABOUT:CONFIG" without quotations in the Firefox address bar and hit enter then answer the You might destroy the world question with Alright I'm ready.

3) Right click on the background of the Config screen and then highlight to click on the "New String" choice... When the box comes up enter "general.useragent.override" without quotations and hit return

4) When another box appears paste in your current User Agent string you copied in step 1) BEFORE hitting enter place your cursor on your paste and right arrow to the end of the line. EDIT/REPLACE "6.0" with "5.0.1" without the quotations. Enter your change and close out the Config page.

5) Repeat step 1) to make sure the User Agent string is now spoofing your browser as version 5.0.1

6) Go to Netflix and watch movies (Make sure Silverlight and the Firefox Java are on). If it was working before the upgrade, everything should now work again streaming Netflix with Firefox 6.0.

7) Call Netflix and tell them Dave sent you to see if they're stupid or just lazy and to quit spreading the B.S. that Firefox 6.0 ain't workin when we know it's Netflix (1-866-636-3076)

Modified by DavidLee1951

more options

removed duplicate

Modified by DavidLee1951

more options

removed duplicate

Modified by DavidLee1951

more options

This didn't work for me....

more options

Chosen Solution

This also works if you are having trouble with the Mozilla FireFox 10.0 upgrade if you disguise it as 9.0.1 according to DavidLee1951's instructions. Thanks David Lee!