X
Tap here to go to the mobile version of the site.

Support Forum

How To Disable Add on Compatibility Checking

Posted

Just installed firefox 6.0 and even though I did not notice any difference so far compared to firefox 5.0 I did notice an small annoyance. Every time I open Firefox 6.0 now, the add on compatibility check runs! How do I stop it from running every single time??? Firefox 5.0 never used to do that... Regards

Just installed firefox 6.0 and even though I did not notice any difference so far compared to firefox 5.0 I did notice an small annoyance. Every time I open Firefox 6.0 now, the add on compatibility check runs! How do I stop it from running every single time??? Firefox 5.0 never used to do that... Regards

Chosen solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (extensions.sqlite, extensions.ini, extensions.cache, extensions.rdf) and compatibility.ini in the Firefox profile folder to reset the extensions registry.
New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is an update.


Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files

See:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Shockwave Flash 10.3 r183
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0

More Information

kdawg77 0 solutions 1 answers

I just worked it out - like other versions you need to go to about:config and then right click and add a new boolean - calling it "extensions.checkCompatibility.6.0" (turns out the caps is important) and giving it the value false.

Restart FF and that should be your add-ons working again.

I just worked it out - like other versions you need to go to about:config and then right click and add a new boolean - calling it "extensions.checkCompatibility.6.0" (turns out the caps is important) and giving it the value false. Restart FF and that should be your add-ons working again.
cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers
See: *http://kb.mozillazine.org/Resetting_preferences *http://kb.mozillazine.org/Preferences_not_saved

Question owner

Hello Kdawg77, Can you please elaborate more? Where is this about:config?? Sorry I am just a student not very tech-savvy..

Hello Kdawg77, Can you please elaborate more? Where is this about:config?? Sorry I am just a student not very tech-savvy..

Question owner

Sorry disregard post above, cor-el provided clear instruction....

Sorry disregard post above, cor-el provided clear instruction....

Question owner

Hi guys, THe instructions you have provided do not solve my problem. My add-ons work fine, so I don;t think you understood my problem. There is nothing really wrong with firefox, the only problem is every time I start it up, the add-on compatibility check runs. Every single time. Why does it do that, and how do I stop it from checking every single time?

Hi guys, THe instructions you have provided do not solve my problem. My add-ons work fine, so I don;t think you understood my problem. There is nothing really wrong with firefox, the only problem is every time I start it up, the add-on compatibility check runs. Every single time. Why does it do that, and how do I stop it from checking every single time?
cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers

You aren't using that profile with another Firefox version?

Try to delete compatibility.ini in the Firefox Profile Folder in case you have security software that is protecting the file.

You aren't using that profile with another Firefox version? Try to delete compatibility.ini in the Firefox Profile Folder in case you have security software that is protecting the file. *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

I do not have another firefox version, however I just upgraded to firefox 6 and I brought forward all my saved data with MozBackup (from ff 5). Do you think this is what is causing it? Here is an image as well...

I do not have another firefox version, however I just upgraded to firefox 6 and I brought forward all my saved data with MozBackup (from ff 5). Do you think this is what is causing it? Here is an image as well...
cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers

Yes, that is probably the cause if you restored files like prefs.js and compatibility.ini

Yes, that is probably the cause if you restored files like prefs.js and compatibility.ini

Question owner

So whats the only choice? I dont want to loose my bookmarks etc, but I also do not want this checking coming up all the time...

So whats the only choice? I dont want to loose my bookmarks etc, but I also do not want this checking coming up all the time...
cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers

You should only see that check once after you have restored the files.
If you see it with every start then something else is wrong and you can try to remove those files.

You should only see that check once after you have restored the files.<br /> If you see it with every start then something else is wrong and you can try to remove those files.

Question owner

Yes I see it with every single start. So what files do I need to remove and how do I do it? Sorry I am asking too many questions, I am not very tech savvy...thanks

Yes I see it with every single start. So what files do I need to remove and how do I do it? Sorry I am asking too many questions, I am not very tech savvy...thanks
cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers

Did you delete the file prefs.js and maybe also compatibility.ini in the Firefox Profile Folder or excluded them?

Do any files in the profile folder have a read-only attribute or don't have read/write permissions otherwise?

Did you delete the file prefs.js and maybe also compatibility.ini in the Firefox Profile Folder or excluded them? *http://kb.mozillazine.org/Profile_folder_-_Firefox *Help > Troubleshooting Information > Profile Directory: Open Containing Folder Do any files in the profile folder have a read-only attribute or don't have read/write permissions otherwise?

Question owner

Hello, I went to the containing folder and I deleted both prefs.js and compatibility.ini as you said. I then restarted firefox but the check comes up again! (I had 3 prefs.js files).

Hello, I went to the containing folder and I deleted both prefs.js and compatibility.ini as you said. I then restarted firefox but the check comes up again! (I had 3 prefs.js files).

Modified by fireniko

cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers

What about that third file prefs.js or prefs-##.js ?

What about that third file prefs.js or prefs-##.js ?

Question owner

I deleted all of them - still nothing - the compatibility check shows up every time!

I deleted all of them - still nothing - the compatibility check shows up every time!
cor-el
  • Top 10 Contributor
  • Moderator
12142 solutions 112771 answers

Chosen Solution

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the files extensions.* (extensions.sqlite, extensions.ini, extensions.cache, extensions.rdf) and compatibility.ini in the Firefox profile folder to reset the extensions registry.
New files will be created when required.

See "Corrupt extension files":

If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is an update.


Create a new profile as a test to check if your current profile is causing the problems.

See Basic Troubleshooting: Make a new profile:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files

See:

It is possible that there is a problem with the file(s) that store the extensions registry. Delete the files extensions.* (extensions.sqlite, extensions.ini, extensions.cache, extensions.rdf) and compatibility.ini in the Firefox [[Profiles|profile folder]] to reset the extensions registry.<br /> New files will be created when required. See "Corrupt extension files": * http://kb.mozillazine.org/Unable_to_install_themes_or_extensions If you see disabled, not compatible, extensions in "Tools > Add-ons > Extensions" then click the Tools button at the left side of the Search Bar (or click the "Find Updates" button in older Firefox versions) to do a compatibility check or see if there is an update. ---- Create a new profile as a test to check if your current profile is causing the problems. See Basic Troubleshooting: Make a new profile: *https://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems. If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files See: *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

I created a new profile as you said - and the compatibility check did not come up anymore - That fixed the problem - so as you said COR-EL There was probably a problem with a file in the old profile - I guess we will never know what it is - At least now it works fine - I had to backup my bookmarks so I dont loose them. Thanks a lot COR-EL for being patient....

I created a new profile as you said - and the compatibility check did not come up anymore - That fixed the problem - so as you said COR-EL There was probably a problem with a file in the old profile - I guess we will never know what it is - At least now it works fine - I had to backup my bookmarks so I dont loose them. Thanks a lot COR-EL for being patient....