Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

autocomplete changes first 'h' enterd into 'w'

  • 7 replies
  • 135 have this problem
  • 347 views
  • Last reply by markAlpha

more options

in FF4 I'm used to type only the first few characters of the domain name, and waiting for the proposal of the autocomplete feature in order to speedup selection of the particular webpage. Eg: I type 'h' -> list of URL shows up containing 'h' and in the address bar is show 'h' in normal font followed by the suggestion highlighted. I can now type a 'b', the selection narrows down to my favorite website (hbvl.be) and I can hit enter or select a particular subpage.

In Aurora this has changed ... I type 'h' -> a 'w' appears in the adressbar followed by the suggestions made by FF, the remainder of the URL being highlighted. I now type 'b' -> the addressbar shows 'wb' in normal font and no suggestions because 'wb' isn't nowhere in my history or favorites. If I continue 'vl.be' +enter -> wbvl.be which is a different website .... :-( When I start typing 'www.hb.....' everything is normal. I tried other characters, but this only seems to occur with 'h' as first character of the URL I enter !

If wanted I can post a videocapture of this behaviour, because it's quite odd.

Best regards Maurizio

Modified by Morris24

All Replies (7)

more options

Well whats happening is clear

Someone thinks you don't ever need to type http:// so they changed it to start typing www.... but clearly its broken.

I need to visit...

hsbc.com ! hotmail.com !

Stupid, stupid decision.

more options

To restore the http prefix:

  1. Type about:config in the location bar and press Enter.
  2. Use the Filter box to search for trim
  3. Double-click or right-click on the browser.urlbar.trimURLs preference to change its value to false
more options

That will only happen if inline-autocomplete is enabled.

Bug 678352 - 'h' entered as first letter in location bar is overwritten with 'w' when browser.urlbar.autoFill is true

more options

It isn't just with 'h'. Even 'm' turns into a 'w'. Here's what's happening - As you start with the 1st character of the URL you are trying to get to, the auto-complete kicks in, just like in previous versions. The difference now is, even though the typed character is shown in bold, the entire URL after the 1st character is highlighted. When the 2nd character is typed, the 1st highlighted character is replaced with the typed character. Since 'www' is the URL prefix in most cases, 'w' is the 1st un-highlighted. So, typing 'ho' for www.hotmail.com changes into a 'wo' See screen shots attached. Notice the bold h which is what I typed and also notice the entire URL is highlighted, except for the 1st w in www. Same thing happens if I try typing a 'm' for www.msnbc.msn.com. The URL turns into 'ws'

more options

This issue is still happening in version 10.0.1

more options

This is still an open bug. See Bug 678352 (which says that it was fixed but backed out for performance reasons).

more options

It seems that a work-around in the mean time, without disabling anything, is typing the "h" first character of the text entry (since that seems to be the only character that is janking up the system) and then selecting the first suggested result ... then hitting the 'delete' button.