Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I reset default search engine in location bar? (Resetting keyword.URL didn't help)

  • 11 replies
  • 100 have this problem
  • 18813 views
  • Last reply by BoxFreind

more options

My location bar internet keyword searches result in search.yahoo (powered by AVG) but I'd like to set it to google. I manage to set to bing or something else but when I reset the keyword.URL in about:config page, it does not go back to google, but to yahoo. What can I do?

Chosen solution

Open the about:config window and change these settings:

Read this answer in context 👍 4

All Replies (11)

more options

Try modifying the string of keyword.URL to "http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=" without quotes.

Hope this helps

more options

see https://support.mozilla.com/en-US/questions/850287

If the link solves your problem please mark this one as solved.

more options

Chosen Solution

Open the about:config window and change these settings:

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

ahnasr: thanks a lot, this is what i did in the end but it bothers me that the default has changed to something else; which is probably an add-on / extension that i used and even though i removed it, it still remains somewhere in the configuration. finitarry: yes, the browser.search.defaultenginename was set to yahoo search, so i changed that but there was no browser.search.defaulturl to change -which is ok, right? cor-el: i'll try the safe mode again and follow your recommendations.

Modified by banucin

more options

browser.search.defaulturl is not part of Firefox and resetting it would make it disappear. In my answer, I did specifically mark that as okay if it didn't exist. It was probably created and used by the Yahoo toolbar to make changes to the keyword.URL which is what is used in Firefox and was getting reset to point to Yahoo. (configuration variables are case-sensitive).

more options

thanks to all who helped! multiple things are working, do i have to select only one "solution"??

more options

You can change the default engine name and the keyword. That should restore things back to normal. Actually, resetting those should return things to normal.

more options
more options

thanks to all who helped! multiple things are working, do i have to select only one "solution"??''

Yes, as owner only you can mark as solved and you can only choose one answer for that so try to choose the best answer. Anyone can register any answer as helpful or unhelpful which like a solution does not require a comment. You are not the first to find out until afterwards.

Fortunately there weren't any registered as unhelpful but such answers could mean anything from off-topic to good answer for another question but not mine and does not does get a better answer or understanding for anyone without a comment.

If a solution has multiple suggestions it should be made clear which parts helped so people can concentrate a bit on alternatives or on emphasizing most likely portions to be of help.

more options

Make sure you don't have something called "Conduit engine" installed. It is installed with some toolbars and allows you to install "apps" on your browsers toolbar interface. It also resets your "browser.search.defaulturl" and "keyword.URL" settings to redirect keyword searches in the address bar.