X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Somehow ask.com has taken over my homepage and I can not go back to google firefox as the default.

Posted

Somehow ask.com has taken over my homepage and I can not go back to google firefox as the default. I even went to tools page info and tried to have it blocked, but it still comes back. IT'S LIKE AOL!

Chosen solution

I found Safebrowser's reply when I was trying to get rid of AOL and so far it looks like it worked for AOL. I was pulling out my hair - I'd removed everything that even smelled like AOL (they bought Winamp so now Winamp is littered with AOL), but I was shocked to see how many intrusive entries were in Firefox settings by AOL! Thanks for the posting - I'm finally rid of them I hope!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • np-mswmp
  • 1.9.0042.0
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Fun Web Products Plugin Stub for 32-bit Windows
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • 4.0.60310.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • My Web Search Plugin Stub for 32-bit Windows
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Swapnilrustagi 19 solutions 286 answers

See if you have the Ask toolbar installed in Firefox button > Add-ons > Extensions.

SafeBrowser 550 solutions 2392 answers

Helpful Reply

  1. Remove Ask Toolbar (if you have it installed):
  2. Reset your home page: http://support.mozilla.com/en-US/kb/How+to+set+the+home+page
    • You can reset to the default by clicking "Restore to default" on Options > General > Startup > Home page. Be sure to set "When Firefox starts" to "Show my home page" on that same panel.
  3. Reset your Location Bar search engine:
  4. If Ask is shown in your Search Bar and you want to remove it:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You need to update some plug-ins:

nscagal 1 solutions 1 answers

Chosen Solution

I found Safebrowser's reply when I was trying to get rid of AOL and so far it looks like it worked for AOL. I was pulling out my hair - I'd removed everything that even smelled like AOL (they bought Winamp so now Winamp is littered with AOL), but I was shocked to see how many intrusive entries were in Firefox settings by AOL! Thanks for the posting - I'm finally rid of them I hope!

heatherwall1 0 solutions 1 answers

Safebrowser's solution option #3 worked very well for me. Quick and easy solution. Reset your Location Bar search engine:

   type about:config in your Location Bar, like typing a web site address, and press the Enter key
   ignore warning and choose to continue
   in Filter, type keyword.URL
   in lower part of screen, if it is bold and shows "user set", right-click keyword.URL and choose "Reset"
   in Filter, type Ask
   any items in lower part of screen in bold and showing "user set", right-click and choose "Reset"
   close about:config tab