Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webm video won't play in Firefox 5.01. It will work in Chrome.

  • 14 replies
  • 12 have this problem
  • 313 views
  • Last reply by Hasan

more options

I just started experimenting with the html5 video tag. My test WebM file is playing fine in Chrome. It won't play in Firefox 5.01. My test .ogv file will play fine in Firefox 5.01. Any ideas why?

I tried in 5.0 and 5.01.

Chosen solution

The boxes with the big X are explained here for Theora Video (ogg) but the same should apply to WebM:

https://developer.mozilla.org/En/HTML/Element/Video

Server support

It's worth re-emphasizing for the time being, that if the MIME types for Theora video are not set on the server, the video may not show or show a gray box containing an X (if JavaScript is enabled).
Read this answer in context 👍 0

All Replies (14)

more options

Troubleshooting extensions and themes

How do I install the Flash plugin?

Managing the Flash plugin

Check and tell if its working.

more options

Good ideas,

I'm using the basic Firefox theme. I just uninstalled the flash plugin. It still won't play the webm file.

more options

Do you have a link to your WebM video?

What about the WebM videos here? Do they work?

P.S. see HTML5 audio and video in Firefox for more information about open media in Firefox.

Modified by AliceWyman

more options

Hi Alice,

Yes, I was able to play those two videos in firefox. Of course, I don't know if I'm playing the webm or the ogv version.

My webm test video is located at http://bibleoutpost.com/test.html. I just downloaded the firefox webm video from mozilla and put it on the server too. Both videos play in Chrome, neither plays in Firefox from my server.

Modified by foxuser10

more options

Your page doesn't work for me ... I just see two boxes with a big X in each.

I checked the Firefox Page Info window Media tab and these files should open automatically in Firefox, but they don't:

Compare to:

I don't know about your HTML code but the MIME type must be wrong for the files when downloaded from your server - it must not be video/webm
Ref: https://developer.mozilla.org/En/Media_formats_supported_by_the_audio_and_video_elements

You should really go to a forum specializing in HTML and webpage coding ... you could try at MozillaZine's Web Development forum, http://forums.mozillazine.org/viewforum.php?f=25 (you will have to register)

Modified by AliceWyman

more options

Exactly. I just get the two boxes.

If it's MIME type is wrong, why is it working correctly in Chrome?

Thanks for helping.

Modified by foxuser10

more options

Sorry, I don't know anything about Chrome.

P.S. I installed the LiveHttpHeaders extension and then checked the file download from your server. The mimeType is shown as application/octet-stream which is why it's not opening automatically in Firefox.

Ref:

Modified by AliceWyman

more options

Sorry to interrupt your conversation but foxuser10 the website link you provided in of your previous posts doesn't work from here. Its displaying the following message:

404 Not Found

nginx/1.0.5

Modified by Hasan

more options

Take the period off of the link.

http://bibleoutpost.com/test.html

more options

Chosen Solution

The boxes with the big X are explained here for Theora Video (ogg) but the same should apply to WebM:

https://developer.mozilla.org/En/HTML/Element/Video

Server support

It's worth re-emphasizing for the time being, that if the MIME types for Theora video are not set on the server, the video may not show or show a gray box containing an X (if JavaScript is enabled).
more options

The file http://bibleoutpost.com/firefox_movie.webm is send as Content-Type: application/octet-stream

You need to make sure that the server sends the file with a supported MIME type


data:text/html,<object type="video/webm" data="http://bibleoutpost.com/firefox_movie.webm" width="100%" height="100%"></object>

Modified by cor-el

more options

Thanks for confirming, cor-el.

foxuser10 : You have to follow the instructions at https://developer.mozilla.org/En/HTML/Element/Video#Server_support except that you would need:

AddType video/webm .webm
more options

Thanks guys (you rock); this is solved the problem for me. For anyone running nginx instead of apache all you need to do is modify your /opt/nginx/conf/mime.types file.

In the file, you probably already have a line towards the bottom that says

       audio/ogg           ogg;

Change that to be:

       audio/ogg             ogg oga;

At the very bottom, in our video section, add the following:

       video/webm        webm;
       video/ogg            ogv ogm;

Save the file and restart nginx. Webm files should now play correctly in both Firefox and Chrome.

(An .ogg file could be a video file, but it looks like the recommendation is that you rename any movie files to be .ogv.)

more options

Glad to hear it

Modified by Hasan