Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Clicked 'Block' option in error now can't see the website. How do I cancel

  • 16 replies
  • 1 has this problem
  • 8 views
  • Last reply by jimdgrant

more options

Dopey I know but I clicked the 'block' option on the screen then agreed. Now can't view site and don't know what to do to correct this.

Chosen solution

-> Create a New Profile as a test to check if your current profile is causing the problems. See:

Basic Troubleshooting: Make a New Profile

-> If that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile. See this:

Recovering important data from an old profile

Check and tell if its working.

Read this answer in context 👍 0

All Replies (16)

more options
more options

Thanks for your advice. However, I still have problems - can you help? I think I followed the instructions properly the first time but have since repeated them. When I ran the pop up 'test' no sites were listed so guessing that's not an issue. However, since trying to unblock the site which I still cannot access, I have been getting the same 'warning' message with google and the original website. This message informs me that the 'site wants to send a cookie' and has 3 options. When I saw the message I selected the accept option as it was the only one that appeared to do anything. I can get onto my email account but only after selecting the accept option repeatedly. I now get the 'site want to send a cookie message on different sites some with multiple cookies! The original site is displayed but the screen is blank and I cannot see any icons to explore. Sorry to have to come back to you.

more options

Troubleshooting extensions and themes

Clear Cookies & Cache

Clear the Network Cache

-> click Firefox button and click Options -> Privacy -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode -> place Checkmarks on:

1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> click Exceptions... button and click Remove All button -> Now type the addresses of the websites from which you want to Allow Cookies to be stored e.g. login.live.com , mail.live.com , hotmail.com , live.com , msn.com , login.yahoo.com , mail.yahoo.com , yahoo.com , mail.google.com , google.com , etc. -> click Allow for each, One by One 4a) Accept Third-party Cookies -> Keep Until : select They Expire

-> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES

-> click Firefox button and click Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> click Firefox button and click Options -> Advanced -> General -> Remove Checkmark from Warn me when websites try to redirect or reload the page

-> Click OK on Options window -> Restart Firefox

Check and tell if its working.

-> When you use Clear Recent History feature, DO NOT select Cookies, Forms and Search History, Active Logins, Site Preferences

-> If you use Privacy Cleanup softwares like CCleaner, DON'T SELECT FIREFOX IN ITS SETTINGS. These softwares can be responsible for Deleting your Firefox Settings.

more options

Hi thanks again. I have worked through each of the instructions provided in the links plus your text instructions. All seems to be fine but the original website still cannot be accessed. When I key it in it goes to the correct page but the screen is blank. All other sites are fine and I've just checked the site out on another pc and the problem doesn't lie there.  ?

more options

Did you added your concerned Website's Address in the Exceptions part to Allow Cookies ??

more options

Checked and yes I did

more options

-> click Firefox button -> go to History and click Show All History -> Library window will open

-> Search for the website you want to remove from your history by typing its name in the Search History field in the top-right corner and then pressing Enter -> Then, in the search results, right-click on the site you want to remove, and click Forget About This Site

-> Close the Library window -> Restart Firefox

Check and tell if its working.

Modified by Hasan

more options

If my previous reply doesn't solve it, do this:

  • Go to the website you wish to Allow from setting Cookies in Firefox
  • Right-click empty space within the page and click View Page Info
  • In the Page Info window, select the Permissions panel
  • Underneath Set Cookies, place Checkmark on Use Default
  • Change the setting to Allow
  • Close the Page Info window

Check and tell if its working.

more options

Removed website from all day lists and restarted firefox but screen still blank. Could I reinstall firefox to clear the problem or try temporarily another browser? I'm using norton and my bank recently asked me to download some software to protect my passwords but I don't think it can be that as I can't get to the password stage on the site. Really appreciate this help and sorry that its taking up so much of your time.

more options

Sorry don't follow this as when I went to the exceptions area and clicked on the web address nothing happened. Can you please explain again - sorry.

more options

See this: Block cookies for a single site

What you will have to do is that in this page where they have chosen to BLOCK, you will just have to change it to ALLOW. See my Last post top guide you with this.

Check and tell if its working.

more options

OK I have gone to site and right clicked in order to change the site to allow cookies. However, after restarting firefox the screen is still blank. I tested what would happen if I set to block cookies and I can then see the home page pf the site but can't go beyond it. Now resorted back to 'allow' but no progress - sorry.

more options

There have been a lot of suggestions done in this thread and I'm not sure what you have done so far.

Do you remember what you blocked?
Was it something from an extension or an info bar at the top from Firefox or something from security software (firewall)?


You can check the permissions of the domain in the current tab.

  • Tools > Page Info > Permissions

Modified by cor-el

more options

I've worked through each of the suggestions you've made but will happily redo this to ensure that I haven't missed anything. With all other sites when I go to Page Info - Permissions, the' Use Default' and 'Allow' options are checked. However with the site in question each time I check back the 'Allow' is checked but the 'Use Default' isn't. Re what did I block; the word 'block' was displayed at the bottom right hand side of the screen almost on top of the scroll down arrow. Sorry I have no idea what it referred to and I know that I should have been much more careful. I've already checked to see if it could have anything to do with security software from bank by disabling it. I've checked norton but can't see anything obvious. Can you please advise if installing IE as a temporary solution is worth trying or should I run through your earlier suggestions again? Thanks

more options

Chosen Solution

-> Create a New Profile as a test to check if your current profile is causing the problems. See:

Basic Troubleshooting: Make a New Profile

-> If that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile. See this:

Recovering important data from an old profile

Check and tell if its working.

more options

Thank you very much for your help and patience.