X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The keyboard number keys and symbols above them will not work. I nothing at all except a space or they last letter key used, but works fine in other applications such as MS Word. The number pad works just fine. Any one have any thoughts on this.

Posted

I had to do a reinstall and upgrade to Windows 7, so I may have missed something. Running a 64bit OS. Problem only seems to be in the browsers.

Chosen solution

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.3 r181
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Hasan 477 solutions 5600 answers

You may have Switched ON Caret Browsing. press F7 (on Mac: fn + F7) to toggle Caret Browsing ON/OFF

  • click Firefox button and click Options -> Advanced -> General -> remove Checkmark from Always use the cursor keys to navigate within pages

Check and tell if its working.

Question owner

Gave that a try. the Caret Browsing was off and there was not a check mark on the "Always use the cursor keys to navigate within pages". So no dice, I even put a different keyboard on with the same results.

Thanks for the suggestions.

onedave 0 solutions 1 answers

I had this problem after installing Adobe Flash Player 10.3.183.5. I have Windows 7 and Firefox 5. I later found out the Adobe Flash Player installation was unsuccessful so I installed it again, this time successfully, and my keyboard problems went away!!

Hasan 477 solutions 5600 answers

Chosen Solution

Troubleshooting extensions and themes

Troubleshooting plugins

Check and tell if its working.

Question owner

Did a reinstall of flash and it worked only for one reboot of firefox and then the problem returned. Sure looked like that was going to work. Thanks

Question owner

Gave all of your suggestions a try without success. There is a conflict going on some where as the problem will go away when the OS in booted into Safe mode with networking. I just cannot seem to find it, thanks for the help and suggestions.

Hasan 477 solutions 5600 answers

-> click Firefox button and click Options -> Advanced panel -> General tab -> Remove Checkmark from Use Hardware Acceleration when available -> click OK

Check and tell if its working.

Question owner

Found a solution to this problem. Comcast has a product bundled with their Norton antivirus suite called Constant guard. When I removed it the number and symbols keys above the alpha keys began to function properly in Firefox and other browsers. Thanks for the helpful suggestions.

Hasan 477 solutions 5600 answers

You are welcome

Modified by Hasan

nightwing19 0 solutions 1 answers

I have that comcast bundle too.I tried your suggestion and it worked for me. thank you

Modified by nightwing19