X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox will not hold my Homepage Selection

Posted

I have tried two ways to mark my Homepage: General Tab "use current" at selected Page - then OK. Then I tried the suggested moving that page's icon to the "home" icon and confirming that I want THAT page as my Home Page.

When I open a new window, I only get the 3 pages I got when I upgraded to new version of Firefox - these methods do not hold my desired page as a "Homepage"

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 12.0.1.647
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Shockwave Flash 10.3 r181
  • DivX Web Player version 2.1.2.265
  • DivX VOD Helper Plug-in
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Application Basics
Name
Firefox
Version
5.0.1
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110707182747
browser.startup.homepage_override.mstone
rv:5.0.1
extensions.lastAppVersion
5.0.1
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
16045
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
RADEON X300 Series
Vendor ID
1002
Device ID
5b60
Adapter RAM
Unknown
Adapter Drivers
ati2dvag
Driver Version
6.14.10.6476
Driver Date
8-25-2004
Direct2D Enabled
Blocked on your graphics driver. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled
false (0.0.0.0, font cache n/a)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
0/1

Xircal 334 solutions 3835 answers

To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the Firefox button, go to Options | Options | General.

  • Make sure it says Show My Homepage in the first dropdown menu and not "Show my windows and tabs from last time".

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.


If this suggestion resolves the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

Question owner

Thank you. That's one of the things I tried, exactly as you describe. Sadly that did not work. Perhaps there's a setting that clears the memory when I get away from the page? -still trying things...

Hasan 477 solutions 5600 answers

Preferences are not saved

https://support.mozilla.com/en-US/kb/Preferences%20are%20not%20saved

Check and tell if its working.

Question owner

Ok. Followed instructions. I see the problem - - will not let me delete prefsjs file as it is Corrupted and Unreadable - now what? ~Thanks~

Question owner

The file is corrupt - but tried following instructions to delete file(s) and my system will not let me do that.

Hasan 477 solutions 5600 answers

see the middle to end part of the link i provided in my previous post

Question owner

Thank you. Yes. Tried it - my system will not let me delete those files. I'm just going to use Google Chrome for now - this is not worth any more time and effort

Xircal 334 solutions 3835 answers

You cannot delete the file while Firefox is running. Close Firefox first.

Question owner

I am following directions carefully - Firefox windows are all closed. The only thing I have open is that folder I was instructed to open - when I go to delete the file I get an error saying that it's Corrupt and Unreadable and will not let me delete it. I've tried 3 times now.

Hasan 477 solutions 5600 answers

Open the link i posted earlier in another web browser and Close Firefox (click Firefox button and click Exit) or (ALT + F -> Exit). Wait for 10-15 seconds just to ensure that Firefox is closed. For confirmation, Open Task Manager, go to Processes section and Delete firerfox.exe process (if it is still there though it should not be there now)

Now perform the steps suggested in the article.

Check and tell if its working.

Question owner

NO -still will not let me do it - message I get is: "Cannot delete prefsjs file as it is Corrupted and Unreadable". It simply will not let me do it.

Hasan 477 solutions 5600 answers

Corrupt or Damaged prefs.js file

http://kb.mozillazine.org/Preferences_not_saved#Corrupt_or_damaged_prefs.js_file

Check and tell if its working.

Question owner

Started in Safe Mode, reset as instructed - still no help . I'm getting very tired of wasting my time with this - I am seriously going to stop using Firefoxo = it is not worth this frustration. Thank you.

Question owner

I don't have these kind of problems with ie or Google Chrome - and, frankly, the last 2 versions of Firefox did not work well on my system - I keep going back to the other browsers. Simply unhappy with your product.

Hasan 477 solutions 5600 answers

-> Exit Firefox completely

-> Delete the user.js file, if found, or move it to a backup location (this file does not exist by default).

-> Delete the prefs.js file (or move it to backup). (If you find multiple numbered prefs.js files or a read-only prefs.js.moztmp file, delete those files as well

When you next reopen Firefox, it will rebuild the prefs.js file from program defaults. This will restore the default values of preferences displayed and restores the default theme.

Check and tell if its working.

Modified by Hasan

Question owner

Nope - thanks anyway. Although I appreciate your efforts, I am ABSOLUTELY DONE with Firefox - the last 2 versions were nothing but trouble. IE an Google Chrome work just fine. I have had ENOUGH.

Hasan 477 solutions 5600 answers

Create a new profile as a test to check if your current profile is causing the problems. See:

Basic Troubleshooting: Make a new profile

https://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins"

Check and tell if its working.

Modified by Hasan

Question owner

Please Stop. I'm no longer accepting responses nor wasting any more of my life on this. Thank you.