X
Tap here to go to the mobile version of the site.

Support Forum

How do I disable transparency for the menubar and addressbar in firefox?

Posted

How do I disable transparency for the menubar and addressbar in firefox? (This does not mean disable windows aero or transparency in windows 7. A workaround has been posted. Stop spamming threads with disable transparency and aero everytime someone asks about this.) It is difficult to read.

Edit: Is there a setting to tone down the Aero usage of the in Firefox 5 so it looks more like Firefox 3.6. Is there a way to do this in the preferences or inside about:config?

I know what Aero is and how to turn it off.

The 2nd reply has images attached show why it is difficult to read. An light spot on a desktop background or an icon can make it very difficult to read. This is the #1 reason why I keep going back to 3.6.

How do I disable transparency for the menubar and addressbar in firefox? (This does not mean disable windows aero or transparency in windows 7. A workaround has been posted. Stop spamming threads with disable transparency and aero everytime someone asks about this.) It is difficult to read. Edit: Is there a setting to tone down the Aero usage of the in Firefox 5 so it looks more like Firefox 3.6. Is there a way to do this in the preferences or inside about:config? I know what Aero is and how to turn it off. The 2nd reply has images attached show why it is difficult to read. An light spot on a desktop background or an icon can make it very difficult to read. This is the #1 reason why I keep going back to 3.6.

Modified by deerinheadlights

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed firefox 4+

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

alan_r 127 solutions 1451 answers

Sounds like the Windows Aero feature. To turn off transparency -

Right click on Desktop>Personalize>Window Color(at the bottom)>uncheck Enable transparency.

Sounds like the Windows Aero feature. To turn off transparency - Right click on Desktop>Personalize>Window Color(at the bottom)>uncheck Enable transparency.

Question owner

How do I disable transparency for the menubar and addressbar in 'firefox? Transparency in the titlebar is fine with me. See attached images.

How do I disable transparency for the menubar and addressbar in 'firefox? Transparency in the titlebar is fine with me. See attached images.

Modified by deerinheadlights

alan_r 127 solutions 1451 answers

That definitely seems to be Windows Aero. There is no way I know to set that selectively.

You should try a different theme or a persona would probably help.

That definitely seems to be Windows Aero. There is no way I know to set that selectively. You should try a different theme or a persona would probably help.

Question owner

Since my screen captures are missing on previous post I am adding them again to this post. Question has been updated for clarity.

Since my screen captures are missing on previous post I am adding them again to this post. Question has been updated for clarity.
alan_r 127 solutions 1451 answers

I stand by my previous answer.

In Fx5 most of us have the Menu Bar hidden and the orange Firefox button showing. You could also try Tabs on Top. This re-positioning of the toolbars might help.

Right click on toolbar space>Uncheck Menu Bar>Check Tabs on Top.

I stand by my previous answer. In Fx5 most of us have the Menu Bar hidden and the orange Firefox button showing. You could also try Tabs on Top. This re-positioning of the toolbars might help. Right click on toolbar space>Uncheck Menu Bar>Check Tabs on Top.
David McRitchie 320 solutions 3092 answers

Helpful Reply

If you are up to tweaking some CSS code in a style see "Color Toolbar(s) to identify profile (DM*)" -- in http://userstyles.org/styles/9514, and you must read all of the description material understand what has to be done.

It is a style, and playing with the code is what styles are about. You will have to copy the section of code in the description to the bottom of the style for it to be complete to remove additional Aero effects, and choose two or three colors for the toolbars.

If you are up to tweaking some CSS code in a style see "Color Toolbar(s) to identify profile (DM*)" -- in http://userstyles.org/styles/9514, and you must read all of the description material understand what has to be done. It is a style, and playing with the code is what styles are about. You will have to copy the section of code in the description to the bottom of the style for it to be complete to remove additional Aero effects, and choose two or three colors for the toolbars.

Question owner

Thank you, dmcritchie. The link was helpful. I was not able to able to figure out how to use "Color Toolbar(s) to identify profile (DM*)". There was a easier to configure alternative link on that page: "Firefox: Choose Your Color" http://userstyles.org/styles/33773/firefox-choose-your-color

I am going back to 3.6.x if a future update breaks this addon. This feature should be in firefox as a preference.

edit attached image of new look.

Thank you, dmcritchie. The link was helpful. I was not able to able to figure out how to use "Color Toolbar(s) to identify profile (DM*)". There was a easier to configure alternative link on that page: "Firefox: Choose Your Color" [http://userstyles.org/styles/33773/firefox-choose-your-color] I am going back to 3.6.x if a future update breaks this addon. This feature should be in firefox as a preference. edit attached image of new look.

Modified by deerinheadlights

Xircal 334 solutions 3835 answers

See this article on how to reduce the transparency: http://www.helium.com/items/2146148-how-to-adjust-transparency-in-windows-7

Also, try using a different Persona i.e. one which displays the text in a black font rather than a white one. it may not be to your liking, but I use this one which has a subtle fading dot effect: https://addons.mozilla.org/en-US/firefox/addon/carbone/

You can store several Personas in the Appearance menu which you can access by hitting CTRL+SHIFT+A. Then click the link to Appearance, so don't be afraid to try others.


If this suggestion resolves the problem for you, please click the Solved it button next to this post after you log in into the forum. This will help others searching for a solution to the same problem.

Thanks.

See this article on how to reduce the transparency: http://www.helium.com/items/2146148-how-to-adjust-transparency-in-windows-7 Also, try using a different Persona i.e. one which displays the text in a black font rather than a white one. it may not be to your liking, but I use this one which has a subtle fading dot effect: https://addons.mozilla.org/en-US/firefox/addon/carbone/ You can store several Personas in the Appearance menu which you can access by hitting CTRL+SHIFT+A. Then click the link to Appearance, so don't be afraid to try others. ---- If this suggestion resolves the problem for you, please click the '''Solved it''' button next to this post after you log in into the forum. This will help others searching for a solution to the same problem. Thanks.
foxyjm 0 solutions 8 answers

This was driving me scatty because I have vision problems and the transparency feature made reading most difficult. Thank you Alan.

This was driving me scatty because I have vision problems and the transparency feature made reading most difficult. Thank you Alan.