Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I get the wrong website

  • 20 replies
  • 8 have this problem
  • Last reply by Xircal

more options

When I enter the name of a website in my FireFox browser, it links me to a completely different website... On other occasions it even presents me with (I guess) randomized error messages...

When I enter the name of a website in my FireFox browser, it links me to a completely different website... On other occasions it even presents me with (I guess) randomized error messages...

All Replies (20)

more options

Sounds like you have a browser hijacker installed which is redirecting your searches.

First thing to do is to download a malware scanner to eliminate that as the culprit. You can get a free one from here: Run a full system scan and remove anything it finds.

If it is a Trojan virus infection, then it may prevent you from visiting that site. In that particular case, download to another computer (at work, or to a friend's PC) and then copy it to a USB Flash Drive. As a precaution, rename it to something random first i.e. "Yoda1937.exe". That's primarily because viruses are very sophisticated these days and hold their own databases of all the apps designed to remove them. By renaming it to something else, you circumvent the virus's built-in protection.

Do the following if the problem persists.

  1. In the location bar where you normally type in a web address, type about:config and hit Enter.

  2. In the filter at the top, type: keyword.URL

  3. Double click it and remove whatever's in there and replace it with and then click OK.

  4. Close the tab

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.

To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the Firefox button, go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.
more options

Dear Xircal,

Many thanks for the reply and I could download it and I used the Malwarebytes' programme. Unfortunately there were no viruses of any kind on my computer (I already used AVG, Ad-Aware and WinASO myself, and none came out of these either). I didn't get the keyword.URL part, but I tried it, and that didn't work out either unfortunately... Hope you, or someone else, might have another idea as how to deal with this problem..?

Best wishes,


more options

Try scanning for rootkits. It could be that you have picked up something extremely nasty. There are specialized rootkit scanners available.

more options

Explanation of "keyword.URL" here:

Could you check and see what is listed there? I've included a screenshot of what Firefox looks like with that value displayed.

As you can see, I've typed in "about:config" in the location bar at the top and "keyword.URL" in the filter underneath that. The search engine you see listed there is the one I use which is

If yours is not Google, Yahoo, Bing or one of the other well known ones, could you please right click "keyword.URL" and choose "Copy Value" from the menu. Then paste it here. You can either right click and choose "Paste" from the menu, or hit CTRL+V.

more options

I've done as you said and I understand it now. But I don't think it's to do with the keywords in my browser. Because it happens when I type "http://www." as well... I am now trying to look into the possibility of rootkits.

more options

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select Restart with Add-ons Disabled

Firefox will close then it will open up with just basic Firefox. Now do this:

-> go to View Menu -> Zoom -> click Reset -> Page Style -> select Basic Page Style

-> go to View Menu -> Toolbars -> unselect All Unwanted/Incompatible Toolbars

-> go to Tools Menu -> Clear Recent History -> Time range to clear: select "EVERYTHING" -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache -> click Clear Now

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> go to Tools Menu -> Options -> Advanced -> Network -> Offline Storage (Cache): click Clear Now button

-> Click OK on Options window

-> click the Favicon on SearchBar -> click Manage Search Engines -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious/Incompatible Extensions (Add-ons) -> Restart Firefox

-> go to Tools Menu -> Add-ons -> Appearance section -> REMOVE All Unwanted/Suspicious/Incompatible Themes (Persona) -> Restart Firefox

You can enable your Known & Trustworthy Add-ons and Themes later. Check and tell if its working.

more options

I understand what you're saying, but "keyword.URL" determines which search engine is used to display the results. If you look at that location, it will tell you which one is being used. With that information, we can determine whether you have a browser hijacker installed or not.

more options
more options


Can you recall the syntax of any of the random messages you've seen?

more options

Its just all the standard error messages ranging from "404 not found" to a security certificate problem and "object niet gevonden!" and other messages I cant recall at the moment..

more options

Error loading web sites

Check and tell if its working.

more options

For instance

Not Found

The requested URL /wiki/Rootkit was not found on this server. Apache/2.2.17 (Unix) Server at Port 80

When I, perhaps ironically, try to access the Dutch wikipedia site on 'rootkit'

more options

Check my previous post.

more options

Je kan een gratis rootkit-scanner laten downloaden van Microsoft:

Maar, volgens mij heb je geen rootkit op jouw systeem indien je het bericht "object niet gevonden" ziet.

Hoe zit het met Internet Explorer? Lukt het om te surfen met deze browser? Als dat wel zo is, dan zit het probleem bij de firewall. Controleer alles door dit article raad te plegen: Configure firewalls so that Firefox can access the Internet

more options

Same problems with IE, but when I look into the support/ weblink above, I still end up with having malware...

more options

Which site are you trying to get to?

more options

This evening it's which doesn't work... Both in IE and FireFox.

The error here is: 503 Service Unavailable No server is available to handle this request.

Modified by Yoda1987

more options

Try creating a new Profile. See these articles which explain how to create one, and if it solves the problem, how to move your data such as passwords, customizations etc., to the new one.

more options

That didn't solve it, unfortunately. Perhaps I should ask my internet provider, whether it might be something to do with their servers?

more options

503 errors mean the server is overloaded and is therefore unable to handle the request.

Please see this site which may help you resolve the issue: