X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Security Certificate

Posted

Query:

Good afternoon, I have windows 7 and I´m using Internet Explorer but when I get into hotmail, using firefox (latest version 5) or chrome, this program tells me that the certificate has expired and not how to fix this.

The system date is correct and there is no virus in the pc because I had examinated with my antivirus ESET NOD32 4.0.474.0.

The message is: secure.shared.live.com443 uses an invalid security certificate. The certificate expired on 07/07/2011 21:00.

This problem it´s just about Hotmail, what solution you can offer?

Thank you for your attention.

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60531.0
  • Office Live Update v1.3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

Query:
Good afternoon,
I have windows 7 and I´m using Internet Explorer but when I get into hotmail, using firefox (latest version 5) or chrome, this program tells me that the certificate has expired and not how to fix this.
The system date is correct and there is no virus in the pc because I had examinated with my antivirus ESET NOD32 4.0.474.0.
The message is: secure.shared.live.com443 uses an invalid security certificate. The certificate expired on 07/07/2011 21:00.
This problem it´s just about Hotmail, what solution you can offer?
Thank you for your attention.

Helpful Reply

The attached picture.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96740 answers

Helpful Reply

Which certificate is meant by that error message?

Check the pref browser.xul.error_pages.enabled on the about:config page and make sure that the value is set to the true (default).

You can retrieve the certificate and check the certificate.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button to inspect the certificate and check the name of the certificate.

See if you can locate that certificate in the certificate manager.

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.

Question owner

Good afternoon, thanks for your attention but I have not still able to solve this problem, although I have done all the instructions that you tell me. All is alright but I can´t find solution with this problem. I would like that you tell me another possibility. Then I attach these pictures.

there's more things that I can do it? Thank you so much for your attention.

I´m looking forward your answer.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96740 answers

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Question owner

Hi, I have checked the time and the date in my computer and all is alright. Also I have synchronized the servers used to configure the hour of internet.

Then, I have enabled the access certificates to web pages and users ( look at the third picture)

Finally, I have tried to deactivate the Firewall but the problem is continue. There's more things that I can do it?

Thanks.

Modified by carin3

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96740 answers

You shouldn't set trusted bits for intermediate certificates that show as Software Security Device in the Certificate Manager like I see in that third screenshot. Such bits should only be set for Builtin Object Tokens (root certificates). You can try to remove the intermediate certificate that is related to that error to see if that makes Firefox retrieve and store the correct certificate from the server.

Question owner

I have done the indications that you had recommended me, but everything is the same way. There's more things that I can do it? Thanks.

Question owner

help?

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96740 answers

Rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to remove all intermediate certificates that Firefox has stored by visiting secure websites.
If that helped to solve the problem then you can remove the renamed file cert8.db.old unless you have user certificates that you may want to export first and import them in the new file.
Otherwise you can restore the certificates by renaming (copying) the file back to cert8.db
Firefox will automatically store new intermediate certificates when you visit websites that send them.

Firefox Profile Folder:

Modified by cor-el

Question owner

Change cert8.db to cert8.db.old and continue to the error. Uninstall Firefox and profiles and reinstal and continue to the error.

There's more things that I can do it? Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96740 answers

I see that you have a file cert_override.txt that stores exceptions that you have made.

You can also try to rename the file cert_override.txt (cert_override.txt.old) in the Firefox Profile Folder to remove all permanent exceptions that you have saved.

Question owner

I did the above steps did not work. Subsequently, I deleted the cert_override.txt.old and does not work. Attached pictures of the steps above and add that I have installed. Could it be that the antivirus NOD32, giving me some problems? I do not understand why he says that the certificate has expired .... Thanks.

Question owner

help?

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96740 answers

If multiple browsers are affected that that would indicate that the problem is not with Firefox, but elsewhere.

Does it work if you boot the computer in Safe mode with network support enabled via F8 on the boot screen ?