Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I click on :Bookmarks" the drop down list will not stay viewable. It flickers off and on.

  • 15 replies
  • 17 have this problem
  • 855 views
  • Last reply by wperro

more options

When I click on "Bookmarks" the drop down list flashes momentarily and is then not viewable. If I hover the cursor over the list, each bookmark will flash momentarily and then not be viewable. The list is actually still there because when I hover where it should be, the hyperlink is shown in the lower left of the window.

Chosen solution

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

Read this answer in context 👍 3

All Replies (15)

more options

Try the Firefox SafeMode.
A troubleshooting mode, which disables most Add-ons.
(If you're not using it, switch to the Default Theme.)

  1. You can open the Firefox 4/5/6/7 SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  2. Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.

If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

more options

The fix suggested worked. I sincerely appreciate the fast response and good advice.

more options

You're welcome. I am curious which add-on was causing that problem for you, it might help another user who has this same problem if you tell us which extension that problem was caused by.

Also, please click the Solved It button next to the answer that answered or solved your Firefox support issue, it appears when you are logged in, so this thread gets marked as Solved to help other users who may have this same problem.

more options

Never had the problem to that the extent described , problem would occur as soon as moving off of the first menu to try to select from another. Although the menus don't seem as touchy as they used to be.

This works for me, after opening menu click on "Ctrl" key.

Stay-Open Menu :: Add-ons for Firefox

If you followed up on Ed's suggestion and how to track down the extension what extension caused the problem.

more options

Best I can tell, it was the "Bloody Red" skin. Once it started happening, I tried other skins and the problem would not go away. Guess the damage had already been done.

more options

An extension that might also cause this is Forecast Fox

see https://support.mozilla.com/questions/850617

firefox 4.01 on W7 problems with flickering - forecastfox-users | Google Groups

http://groups.google.com/group/forecastfox-users/browse_thread/thread/15e8c96a1c3c991f
more options

I'll stay away from that extension. I hear that another major Firefox update will be on the way soon using something called "Electrolysis". Maybe that will help with the add-on/extension issues.

more options

I started getting this problem today (was there a recent FF update?)

Disabling Firebug 1.8.4 stopped it happening.

more options

Windows users may have received the Firefox 9.0 update starting Tuesday 12 - 20.

more options

Actually, maybe not the Firebug. Strange. I just enabled SEO Toolbar 1.1.26 and the flickering started again.

more options

I gave up on Firefox 5 months ago because this problem would not go away. Have been using IE9 now. But I did just install the new Firefox 9 (with add-in's disabled) and don't have the flicker anymore. Its finally gone (for now). But during these last 5 months, I have gotten hooked on IE9.

more options

I have a very similar problem. However, the flickering is happening to all drop-downs. (i.e. bookmarks, tools, help, ect, right clicking on images)

The strange part is that it's only happening on one screen of my dual monitor set-up. It works perfectly on the main screen, but it flickers on the 2nd screen.

Main: ASUS ML248 2nd: DELL 1704FPV

The problem is indeed fixed in safe mode.

more options

Chosen Solution

In Firefox 4 and later Safe mode disables extensions and disables hardware acceleration.

Try to disable hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If disabling hardware acceleration works then check if there is an update available for your graphics display driver.

more options

I also had the same problem on a dual-monitor setup. On would flicker and one would not. Strange. I am now sticking with IE9 until this is fix my Mozilla.

more options

The new Firefox 9 update seemed to have fixed the problem until recently. With ALL add-ons disabled, I still get menu flicker. I'm sticking with IE9 for now until Mozilla permanently fixes this problem. Its too frustrating and I don't have the time to fool with.