X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Youtube videos not playing.

Posted

Since updating to Firefox 5 I can no longer play Youtube videos. I get a black box with no audio or video. Youtube does work on Safari. I've updated Adobe Flash, with no improvement.

Chosen solution

In your Tools > Add-ons (or Firefox > Add-ons) do you have RealPlayer Browser Record or do you use any other similar tools that download videos from the web?

If so, can you disable them and restart Firefox to see if that helps. If not, try disabling Protected Mode in Flash with the following steps: http://forums.adobe.com/thread/1018071?tstart=0

We are working with Adobe right now to find out what exactly is happening.


Update: 6/12/12
Please read the article linked below for more info on this problem:
Flash 11.3 doesn't load video in Firefox

Read this answer in context 23

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • Cooliris embbedded in a tab
  • Picasa plugin.
  • WebEx64 General Plugin Container Version 202
  • RealPlayer Plugin
  • iPhoto6
  • Garmin Communicator Plug-in Version 2.9.3.0
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Simple plug-in that handles Citrix connection files
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 4.0.51204.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Java Plug-In 2 for NPAPI Browsers
  • Version 2.1.7.2968
  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Shockwave Flash 10.3 r181

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

jscher2000
  • Top 10 Contributor
2365 solutions 20926 answers

Hi Steve bwbarefoot, to edit a text file in Notepad with elevated privileges, right-click the Notepad icon on the Start menu and choose Run as administrator. Then open the file from within Notepad.

Modified by jscher2000

SteveMacLellan 0 solutions 3 answers

I edited the file and then saved it to my desktop with the same name. Then I copied it from there into the flash directory. A window comes up and asks you if you want to copy and replace it. Say yes.

sw1955 0 solutions 2 answers

I'm having the same problem. Really tired of it too. Looking for another ship.

Valkyrie 0 solutions 4 answers

I found an answer to my problem on mozillaZine. I uninstalled all my Flash Player software again and clicked on this link for a clean and simple Flash Player download. No probs since then!

http://fpdownload.macromedia.com/pub/flashplayer/current/licensing/win/install_flash_player_11_plugin_32bit.exe

Good luck!

Alex

jscher2000
  • Top 10 Contributor
2365 solutions 20926 answers

Hi Valkyrie, after saving the exe, you can right-click and view the properties to see the version. That link currently loads version 11.2.202.235, which is the previous version. That might change to version 11.3 (the conflicting version) in the future, so folks should check before uninstalling/reinstalling or you might be wasting your time.

Valkyrie 0 solutions 4 answers

Many thanks. I won't be updating Flash Player until I absolutely have to. This IT business is a dark art!

sw1955 0 solutions 2 answers

This worked for me too.

ohtsuka 0 solutions 1 answers

Helpful Reply

i got a solution too, but is not adobe the one with the problem, to me it seems that realplayer was the reason, if you modify ur settings on ffox it will do nothing!!! You must modify from realplayer.

1.open realplayer 2. go to preferences 3. download & recording 4. uncheck..enable web download and recording for these installed browsers 5. click ok 6. restart ffox

Do not need to uninstall or disable anything on the fox at least it works for me, still working with everything BUT the downloading and recording from realplayer. Not big deal as u all know is very easy to replace that.

thks to Matt_G for the solution!

Modified by ohtsuka

brwe 0 solutions 3 answers

I'm running 64 bit Windows 7. Apparently, the last time Flashplayer updated, it did so to match that. That's correct for my IE9--the problem is I hardly ever use IE, preferring Foxfire. I went to the Adobe website & downloaded the Flashplayer version specified for Foxfire (using my Foxfire browser) & it seems to have solved my problems.