Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to delete the stored bookmarks

  • 7 replies
  • 14 have this problem
  • Last reply by cor-el

more options

Firefox version 3.6.16

Bookmarks-->Organise Bookmarks ---> Import & Backup ---> Restore

How do I delete the list there ? I dont want Firefox to have any bookmarks backup saved

Many thanks in advance

Chosen solution

Then you can remove the.json backups from the bookmarkbackups folder like I wrote above.

Read this answer in context 👍 2

All Replies (7)

more options

You can remove the JSON files in the bookmarkbackups folder in the Firefox Profile Folder.

Set the pref browser.bookmarks.max_backups to 0 if you do not want to create JSON backups automatically.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

more options

Depending on your reasons for asking this, have you considered using the private browsing

more options

The matter is. I have to lend my laptop for a month to a colleague. I don't want to uninstall firefox. So , I deleted all my bookmarks.

But , if my colleague navigates to : Bookmarks-->Organise Bookmarks ---> Import & Backup ---> Restore

he will have the ability to bring all of them back again.

There are 5 or 6 entries in this list (with various dates). These entries is what I want to delete permanently.

more options

Chosen Solution

Then you can remove the.json backups from the bookmarkbackups folder like I wrote above.

more options

Thanks a lot. Finally I found these .json files and deleted them all. Regards George

more options

Please click the Solved It button next to the answer that solved your Firefox support issue, it appears when you are logged in, so this thread gets marked as Solved to help other users who may have this same problem.

more options

You're welcome