X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Windows 7 - Firefox 5 pinned taskbar icon not utilizing pinned icon when opening Firefox

Posted

In Windows 7, when I pin Firefox 5 to the task bar and open it, it opens a completely new Firefox window and doesn't utilize the pinned tab. So I have 1 Firefox pinned, not open, and an addition unpinned Firefox open. This appears to be a bug that it's not consolidating the two firefoxes into the 1 pinned one.

Modified by drsprite

Additional System Details

Installed Plug-ins

  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Winamp Application Detector
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Google Update
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Windows Activation Technologies Plugin for Mozilla
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

Application Basics
Name
Firefox
Version
5.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
1.3.8
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Amazon Toolbar
2.12
true
amznUWL@amazon.com
Flashblock
1.5.14.2
true
{3d7eb24f-2740-49df-8937-200b1cc08f8a}
Forecastfox Weather
2.0.2
true
{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
Java Console
6.0.21
true
{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Xmarks
3.9.10
true
foxmarks@kei.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110615151330
browser.startup.homepage_override.mstone
rv:5.0
extensions.lastAppVersion
5.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1309317384
places.history.expiration.transient_current_max_pages
256410
print.print_printer
PDFCreator
print.printer_PDFCreator.print_bgcolor
false
print.printer_PDFCreator.print_bgimages
false
print.printer_PDFCreator.print_command
print.printer_PDFCreator.print_downloadfonts
false
print.printer_PDFCreator.print_edge_bottom
0
print.printer_PDFCreator.print_edge_left
0
print.printer_PDFCreator.print_edge_right
0
print.printer_PDFCreator.print_edge_top
0
print.printer_PDFCreator.print_evenpages
true
print.printer_PDFCreator.print_footercenter
print.printer_PDFCreator.print_footerleft
&PT
print.printer_PDFCreator.print_footerright
&D
print.printer_PDFCreator.print_headercenter
print.printer_PDFCreator.print_headerleft
&T
print.printer_PDFCreator.print_headerright
&U
print.printer_PDFCreator.print_in_color
true
print.printer_PDFCreator.print_margin_bottom
0.5
print.printer_PDFCreator.print_margin_left
0.5
print.printer_PDFCreator.print_margin_right
0.5
print.printer_PDFCreator.print_margin_top
0.5
print.printer_PDFCreator.print_oddpages
true
print.printer_PDFCreator.print_orientation
0
print.printer_PDFCreator.print_page_delay
50
print.printer_PDFCreator.print_paper_data
9
print.printer_PDFCreator.print_paper_height
11.00
print.printer_PDFCreator.print_paper_size_type
0
print.printer_PDFCreator.print_paper_size_unit
1
print.printer_PDFCreator.print_paper_width
8.50
print.printer_PDFCreator.print_reversed
false
print.printer_PDFCreator.print_scaling
1.00
print.printer_PDFCreator.print_shrink_to_fit
true
print.printer_PDFCreator.print_to_file
false
print.printer_PDFCreator.print_unwriteable_margin_bottom
0
print.printer_PDFCreator.print_unwriteable_margin_left
0
print.printer_PDFCreator.print_unwriteable_margin_right
0
print.printer_PDFCreator.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5700 Series
Vendor ID
1002
Device ID
68b8
Adapter RAM
1024
Adapter Drivers
atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.660.0.0
Driver Date
9-18-2009
Direct2D Enabled
Blocked on your graphics driver. Try updating your graphics driver to version 10.6 or newer.
DirectWrite Enabled
false (6.1.7601.17563, font cache 7.54 MB)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
0/1

Question owner

Bueller? Is this the right place to report bugs like this?

SteveF11 0 solutions 1 answers

I also had the same problem. I don't know if it's a bug or not. It seems to have started happening since a recent update.

I may have found a workaround, or fix: 1) Close Firefox and unpin all Firefox Taskbar icons. 2) Start Firefox from its \Program Files (x86)\Mozilla Firefox directory. 3) Right click on the Taskbar icon and select "Pin this program ...".

Now the Firefox Taskbar icon will behave as expected. Close all browsers and the icon remains. Click it and it opens a browser window and shows a border around the icon (one icon only). Middle or Right click it to open additional browser windows and their icons will overlay the original pinned icon.

If the pinned icon was created by dragging the file out of the directory onto the Taskbar, or Right clicking the file and selecting "Pin to Taskbar", then clicking on the Taskbar icon opens a browser and creates a second independent icon in the Taskbar.

I have no idea why, but that's the way it works on my Windows 7, latest updates, Firefox 5.0.

Modified by SteveF11

Amanuense 0 solutions 1 answers

Helpful Reply

First of all, I apologize for my bad English, I'm an Italian FF 5 user and I had this issue too. However I found a workaround!

  1. Unpin the old firefox icon
  2. Go to c:\Program File (x86)\Mozilla Firefox\
  3. Double click on "firefox.exe"
  4. A Firefox windows will appear, in the supertaskbar a firefox's icon will appear, too.
  5. Pin the new icon by a right click on it and select "Pin to Taskbar"
  6. The firefox's icon will tourn in a whitebox
  7. Make sure that you see the hidden folders (Microsoft Knowledge Base)
  8. Go to C:\Users\%yourusername%\AppData\Local
  9. Delete "IconCache.db"
  10. Open the taskmanager
  11. Kill explorer.exe by clicking on End Process
  12. In the taskmanager, File -> New Task (Run...) --> write "explorer.exe" without the quotation mark, press ok
  13. Problem (hopefully) fixed

Again, excuse me for my bad English

Modified by Amanuense

PROM3TH3US 0 solutions 1 answers

Helpful Reply

There are 2 ways to fix this. The first way if you are using the default Firefox icon:

1.Pin the Firefox to the taskbar. Click on the pinned Firefox to open the duplicate

2.Click on the duplicate Firefox icon that's open and pinned that to the taskbar

3.Unpin the original Firefox icon

If you plan on changing Firefox Icon instead of the default

1.use that same method above but do not change the icon just yet

2.now make sure that the browser is close. hold down SHIFT+right click on the Firefox that's pinned to the taskbar

3.change the icon of your choice through Properties

4.copy and paste this line below into your START and run it. Your explorer will refresh and you will see your new icon for Firefox

TSKILL EXPLORER

Modified by PROM3TH3US

kukusfsf 0 solutions 1 answers
just follow
1) Close Firefox and unpin all Firefox Taskbar icons. 2) Start Firefox from its \Program Files (x86)\Mozilla Firefox directory. 3) Right click on the Taskbar icon and select "Pin this program ...".

Now the Firefox Taskbar icon will behave as expected. Close all browsers and the icon remains. Click it and it opens a browser window and shows a border around the icon (one icon only). Middle or Right click it to open additional browser windows and their icons will overlay the original pinned icon.

mulțumesc mult