X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I don't want Yahoo as my Firefox search engine; I want Google!! How do I get Yahoo out of my computer cause I can't find it in the control panel. It's like Yahoo's a Virus!!! AAAHHH

Posted

Yahoo infiltrated my computer by downloading a free program that i realized was no good. removed the program since, however yahoo is still here and replaced my google search engine on firefox. I can't find it on add/remove programs on my PC and it's driving me nuts. I now have to use google chrome. I miss my google firefox I've removed Firefox and re-downloaded it and it doesn't help. please help me

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • 12.0.1.647
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

David McRitchie 321 solutions 3089 answers

Helpful Reply

Yahoo Toolbar messes up Location Bar Search

Remove the Yahoo Toolbar

  1. "Ctrl+Shift+A" (Add-ons Manager)
  2. Select Puzzle piece on left-side for Extensions List
  3. Find "Yahoo Toolbar" and click on "Uninstall" button, and restart Firefox. (if you really need to keep the Yahoo toolbar, you can hide the toolbar instead with customize, and still change all the search defaults as below)

Then to fix the default search engine used at the Location Bar, change the value of keyword.URL in about:config to one of the values shown in Location Bar search at MozillaZine.

  1. type in about:config into the location bar (in a new tab)
  2. if the warning message nonsense comes up uncheck the box before dismissing the dialog message
  3. filter on keyword
  4. right-click on keyword.URL and choose "modify" then paste in the Google search engine string of your choice.
  5. filter on keyword
  6. right-click on browser.search.defaulturl and again choose "modify" then paste in the Google search engine string of your choice.
  7. right-click on yahoo.ytff.search.popup_src (if it exists, and not empty) and again choose "modify" then paste in the Google search engine string of your choice.

Avoiding the problems: Many software installations contain additional baggage know as crapware. The Yahoo Toolbar is packaged with Java picture

More information on ask.com, Yahoo Toolbars

More information on configuration variables available in about:config entries and for users not familiar with the process there is about:config (How to change).

bluecrop 0 solutions 2 answers

How do I do this on a Mac?

David McRitchie 321 solutions 3089 answers

Ctrl key is same as Command key on the Mac for most keyboard shortcuts. The Addons-Manager can also be reached through

  Tools > Add-ons         if you have the menu bar,  

or with the default Firefox 4 and Firefox 5 toolbars

  "Firefox" > Add-ons    (are in the second column of the drop-down)

Everything else should be the same.

rahman13 0 solutions 5 answers

I tried to do this and know things are even worse. If I type something in it doesn't even search, it just opens up the Google home page. Before at least it used to search on Yahoo! I tried installing the Yahoo toolbar again but that didn't work. How do I get it to search. Instead of just opening a page.

MizLiz 1 solutions 32 answers

Helpful Reply

I just discovered a solution! Go to the upper right hand corner in Firefox where the search bar is. Click on the icon and you'll get a drop-down menu. Go to "manage search engines". You can then delete all the no-good ones, like Bing and Yahoo.

d828 0 solutions 2 answers

This was VERY helpful. However, the drop down meny was at the LEFT of the Search bar on my Firefox 4.0.1. Therefore, I went to upper LEFT hand corner in Firefox where the search bar is. Click on the icon and you'll get a drop-down menu. Go to "manage search engines". You can then delete all the no-good ones, like Bing and Yahoo! THANK YOU, THANK YOU, THANK YOU!!!

d828 0 solutions 2 answers

This did not help me. However, someone else suggested to go to the drop down menu (on the LEFT of the Search bar on my Firefox 4.0.1 but on the RIGHT of the Yahoo Search Bar others). Therefore, I went to upper LEFT hand corner in Firefox where the search bar is, Clicked on the icon and got a drop-down menu. Go to "manage search engines". You can then delete all the no-good ones, like Bing and Yahoo!  :-)