X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 5 is displaying the right fonts only in Safe Mode!

Posted

After upgrading to Firefox 5, i've noticed it's displaying the wrong fonts (bigger than they should - they looked ok in Firefox 4.x, Chrome, Opera).

The strange thing is if i start Firefox 5 in Safe Mode, it displays it correctly. I've disabled all the addons, i've cleaned all the Cache, setup the minimum font size... even reinstalled. It's looking ok only in Safe Mode.

What else to do?

After upgrading to Firefox 5, i've noticed it's displaying the wrong fonts (bigger than they should - they looked ok in Firefox 4.x, Chrome, Opera). The strange thing is if i start Firefox 5 in Safe Mode, it displays it correctly. I've disabled all the addons, i've cleaned all the Cache, setup the minimum font size... even reinstalled. It's looking ok only in Safe Mode. What else to do?

Chosen solution

In Firefox 4 Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

Try to toggle some of the Boolean gfx.font_rendering prefs on the about:config page to disable some features.
Filter: gfx

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

Read this answer in context 4

Additional System Details

Sites Affected

http://www.consolegames.ro

Installed Plug-ins

  • D'Fusion @Home Web Plug-In (2.20.10109.0)
  • Google Update
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_25 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Activation Technologies Plugin for Mozilla
  • 4.0.60531.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

Windows 7 64bits, Firefox 5

Question owner

I am uploading some screenshots to show you the difference between Safe Mode and Normal Mode. I also tested on another computer and it looks like my Firefox in Safe Mode. So, how do i fix it? :)

I am uploading some screenshots to show you the difference between Safe Mode and Normal Mode. I also tested on another computer and it looks like my Firefox in Safe Mode. So, how do i fix it? :)
bentodegier 0 solutions 1 answers

Helpful Reply

I have the same issue. Everything looks messed up small when compared to the previous version of FF and Chrome or IE.

Please fix, i can't use Firefox now because it gives me headaches.

I have the same issue. Everything looks messed up small when compared to the previous version of FF and Chrome or IE. Please fix, i can't use Firefox now because it gives me headaches.
cor-el
  • Top 10 Contributor
  • Moderator
16701 solutions 151028 answers

Chosen Solution

In Firefox 4 Safe mode disables extensions and disables hardware acceleration.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

Try to toggle some of the Boolean gfx.font_rendering prefs on the about:config page to disable some features.
Filter: gfx

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

In Firefox 4 [http://kb.mozillazine.org/Safe_mode Safe mode] disables extensions and disables hardware acceleration. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" ---- Try to toggle some of the Boolean gfx.font_rendering prefs on the about:config page to disable some features.<br /> Filter: gfx To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br /> You can use the Filter bar at to top of the about:config page to locate a pref more easily.

Modified by cor-el

grantgochnauer 0 solutions 1 answers

I am seeing this as well. It seems to have happened after the latest Windows 7 updates. HElp!

I am seeing this as well. It seems to have happened after the latest Windows 7 updates. HElp!

Question owner

Thank you! Disabling hardware acceleration fixed my issue. Now the fonts are displayed correctly! I just hope Mozilla team will find a way to be able to use hardware acceleration and display the right fonts!

Thank you! Disabling hardware acceleration fixed my issue. Now the fonts are displayed correctly! I just hope Mozilla team will find a way to be able to use hardware acceleration and display the right fonts!
ptepper 0 solutions 2 answers

I tried this and it did not solve the problem. These are the new settings (the defaults are the opposite for each of these):

gfx.font_rendering.cleartype.always_use_for_content;true gfx.font_rendering.cleartype.use_for_downloadable_fonts;false gfx.font_rendering.directwrite.enabled;true gfx.font_rendering.directwrite.use_gdi_table_loading;false

The font change is particularly noticable on facebook, where the fonts are already small and are now smaller because of this bug.

I tried this and it did not solve the problem. These are the new settings (the defaults are the opposite for each of these): gfx.font_rendering.cleartype.always_use_for_content;true gfx.font_rendering.cleartype.use_for_downloadable_fonts;false gfx.font_rendering.directwrite.enabled;true gfx.font_rendering.directwrite.use_gdi_table_loading;false The font change is particularly noticable on facebook, where the fonts are already small and are now smaller because of this bug.
insane_homer 0 solutions 4 answers

Same problem with Firefox 5, but fonts display just fine in Minefield (x64 7a) and as above works ok in safe mode.

I have tried re-installing, resetting fonts, turning hardware acceleration off, disabling and uninstalling Personas add-on. None of those have worked.

so far affecting a few of my regular sites. e.g. www.bbc.co.uk news pages.

screenshots of my problem FF5 Fonts here

Same problem with Firefox 5, but fonts display just fine in Minefield (x64 7a) and as above works ok in safe mode. I have tried re-installing, resetting fonts, turning hardware acceleration off, disabling and uninstalling Personas add-on. None of those have worked. so far affecting a few of my regular sites. e.g. www.bbc.co.uk news pages. screenshots of my problem FF5 Fonts [http://techiegeekuk.blogspot.com/2011/07/firefox-5-fonts-issue.html here]

Modified by insane_homer

insane_homer 0 solutions 4 answers

Problem just being ignored by Mozilla, no official response that this is being looked at? now started getting this on my work machine too!

Both are running Windows 7 x64 SP1.

Can somebody post a link to an old Firefox 4 download all searches seem to route back to downloads for FF5 only :/

Problem just being ignored by Mozilla, no official response that this is being looked at? now started getting this on my work machine too! Both are running Windows 7 x64 SP1. Can somebody post a link to an old Firefox 4 download all searches seem to route back to downloads for FF5 only :/
insane_homer 0 solutions 4 answers

Installed 3.6 again and that works fine, now the fonts are FUBAR in Minefield (x64 7a) !!! wtf?

Installed 3.6 again and that works fine, now the fonts are FUBAR in Minefield (x64 7a) !!! wtf?

Modified by insane_homer

insane_homer 0 solutions 4 answers

It appears the problem is with Windows 7 update - http://forums.whirlpool.net.au/archive/1729318 KB2545698

It appears the problem is with Windows 7 update - [http://forums.whirlpool.net.au/archive/1729318 http://forums.whirlpool.net.au/archive/1729318] KB2545698
bellota_182 0 solutions 1 answers

Helpful Reply

I have since today the same problem, I installed Windows 7 Updates, and now the fonts looks very small, specially in Facebook (very small!!!), I tried to do a Restore System, but it doesn't work (doesn't finished it :S), so, now I don't know what to do! And I don't wanna use Chrome, I love Firefox!

I have since today the same problem, I installed Windows 7 Updates, and now the fonts looks very small, specially in Facebook (very small!!!), I tried to do a Restore System, but it doesn't work (doesn't finished it :S), so, now I don't know what to do! And I don't wanna use Chrome, I love Firefox!
Chaser.David 0 solutions 3 answers

You can find almost every version of Firefox here, look at the right-side bar:

http://filehippo.com/download_firefox/
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/

(please only post links to the official Mozilla servers for downloading Firefox - c)

You can find almost every version of Firefox here, look at the right-side bar: <del>http://filehippo<i></i>.com/download_firefox/</del><br /> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/<br /> <br /> (please only post links to the official Mozilla servers for downloading Firefox - c)

Modified by cor-el

Chaser.David 0 solutions 3 answers

This same phenomenon occurred to me too, when I installed Firefox on my new PC (Win 7 x64 SP1), but after downgrading to FF 4.0.1, it stayed the same, so it's likely that SP1 has an update that makes hardware acceleration available for the browser.

It's especially annoying on the Facebook wall feed (font: Tahoma) and YouTube messages (font: Arial), if I zoom in to maximum, I can see that the font itself is right, but at normal size, it's rendered in a weird way. Just like on MonkY's screenshots.

Please, Mozilla and Microsoft, fix this issue!

This same phenomenon occurred to me too, when I installed Firefox on my new PC (Win 7 x64 SP1), but after downgrading to FF 4.0.1, it stayed the same, so it's likely that SP1 has an update that makes hardware acceleration available for the browser. It's especially annoying on the Facebook wall feed (font: Tahoma) and YouTube messages (font: Arial), if I zoom in to maximum, I can see that the font itself is right, but at normal size, it's rendered in a weird way. Just like on MonkY's screenshots. Please, Mozilla and Microsoft, fix this issue!