X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I stop tabs from "constantly" "reloading" themselves?

Posted

Starting with the Firefox 4 update, tabs appear to keep repeatedly "reloading" themselves somewhat, bogging down my computer quickly when several tabs are open. How can I disable the tabs from "constantly" (or very frequently) "reloading" themselves? I much prefer using the refresh option when I want them reloaded or updated.

Problem History and Effects: Before Firefox 4, I could have many tabs (like 30 or 50) open without a problem. With Firefox 4 (and Firefox 5 to, what so far appears to be, a slightly lesser degree), my computer begins slowing down significantly for each tab after about 5 (or when Firefox and "plugin-container.exe" max out my CPU usage), and takes over 10 or 40 seconds to load a page after about 10 or 15 tabs, instead of only 1 second. When I have a large number of tabs open now, at any given moment, most of them say "Connecting..." in the tab title (the same as they say, for at least a moment, when the page/tab is first opened).

Clarification of "Reloading": I keep referring to the tabs as repeatedly reloading, but I don't really know what they're doing; they just seem like that's what their doing, since they frequently change their page title (or name of the tab) to "Connecting..." and they seem to put a load on my computer that, as far as I can tell, is like the page is loading anew, or has been refreshed. I haven't actually noticed any changes in the pages when they do this thing that seems like some sort of reloading to me, so it obviously, and thankfully, isn't doing the same thing pressing F5 does. Random things like advertisements, or the friends being featured on someone's Facebook page, would change when pressing F5, but they don't with this problem I'm describing.

Closing: In general, I'm very pleased with Firefox, but this feature has been hampering me greatly. I searched for ways to disable it, but didn't find any. It might help if I knew what it's called, and exactly what it's doing.

Thank you.

Modified by weller

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to Firefox 4, and continues with Firefox 5.

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • 1.7.0059.1
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 8.3.0
  • Provides additional functionality on Facebook. See our web site for details.
  • npmnqmp 989898989877
  • Pando Web Plugin
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60531.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Rhapsody Player Engine Plugin
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Chosen Solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).