X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 5 some web sites fonts are not work.

Posted

I try to visit this sinhala language web site using Firefox 5 latest version. Then that site not properly display (Fonts are not work). Then i again downloaded that web site fonts and install them. But again that web site not properly display. If i visit that web site using "Google Chrome" or "IE" i can view that web site properly. This problem only happen for Firefox 5. Older version Firefox 4 work properly with this site. This is that web site fonts download link -http://www.lankaenews.com/font/sinhala_tamil_fonts.zip

Additional System Details

Sites Affected

http://www.lankaenews.com/Sinhala/

Installed Plug-ins

  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

Some Sinhala language are Fonts not work in Firefox 5.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

If I modify the embedded stylesheet and add a line for the local file then it seems to work, but @font-face doesn't seem to work when added to userContent.css and this page reloads constantly.

@font-face {
 font-family: sandaru-n;
 font-style:  normal;
 font-weight: normal;
 src: url(SANDARU0.eot), local(sandaru-n);
}

EDIT:
You can set the pref gfx.downloadable_fonts.enabled to false on the about:config page to disable downloadable fonts and make Firefox use a locally installed font.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

Modified by cor-el

Question owner

I can't understand what your saying. And also i can't register and log-in this web site (https://publishers.kontera.com/) using Firefox. I can login and register that web site using Chrome.

Modified by U-Tag

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

About the login problems:

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

What I wrote about the fonts is that Firefox 5 doesn't use a locally installed font when it is not specified via that @font-face rule.
It works in Firefox 5 with the font installed locally if I remove that @font-face rule entirely or if I add a local(sandaru-n) section, but not with only the eot URL rule for IE.

Question owner

That trick not work friend. So what's the problem. Is it Firefox bug?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Do you mean the second part about the fonts or the first part about the logins?

ierpe 0 solutions 1 answers

Hi,

I have a similar problem. Well kind of.

I'm a webdeveloper and I just finished a website that's using some special fonts in the css. (pilotletters-webfont, LetterGothicStd-Slanted, I dont know if they're common fonts or designer made, I didnt actually do the css design)

It works fine in chrome, ie, safari, opera and also firefox versions 3.x and 5 under Linux, Mac and Windows, BUT, people reported to me that it didn't work for them under ff5 (so far, only Mac users reported it)

On my machines, it works, and I can't seem to be able to reproduce the problem... so kind of hard to track...!

Any suggestions?

Question owner

This is a bug (i think). And also i can't register some web site.

Modified by U-Tag

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

@ierpe:

Without as link to test it, it is hard to say what is wrong, so please provide a link to the web page.

There are some changes regarding @font-face. Also older font types (Type 1) other that TTF and Open Type WOFF may no longer work.



@U-Tag:

This page is probably a better link for changes that affect developers:

Question owner

I face this problem in two different sites. 1st site Fonts not work. 2nd site i can't log-in and register it. (No error show only web page refresh) If i use IE or Chrome i can register that web site and log-in. So that i think this is Firefox 5 problem. No my computer.

Modified by U-Tag

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

For the login problem you can try to clear the cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

On which site do you have the problem with the fonts?

Is that still the page with the Sinhala font?

I've modified my first post to suggest disabling downloadable font by setting the pref gfx.downloadable_fonts.enabled to false.
That will make Firefox use a locally installed font if a font with that name is present, so you need to download and install the font that is used on that website.

Modified by cor-el

Question owner

I already try to log-in that site by delete all cookies and cache files. Then i run Ccleaner for additional delete. But this problem still happen. This site i have fonts issue - http://www.lankaenews.com/Sinhala/ I can't log-in this site - https://publishers.kontera.com/

Question owner

This is that sinhala fonts name - "sandaru_normal3.ttf"

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

You can set the pref gfx.downloadable_fonts.enabled to false on the about:config page to disable downloadable fonts and make Firefox use a locally installed font.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

rkpdesilva 0 solutions 2 answers

Thanks very much for the answer I've the same problem and now it's over,

http://lankadeepa.lk/

for this site too, the fonts didn't work Now it's ok

Will there be a problem in the future for another sites after this change ?

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

All sites that use @font-face to specify a font for IE but that do not include a fallback setting for a locally installed font will be affected. If you encounter such websites then contact them and ask them to update their CSS code and specify a local font.

linfusun 0 solutions 1 answers

I had this problem all morning and then located the issue; it's the truetype syntax (has to start with a capital "T":

src:url('../fonts/skia_web.ttf') format('Truetype');

mana82 0 solutions 1 answers

This work for me.

Thanks