X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I set Google as the default search engine in Firefox 5? I have tried several fixes but I keep getting a Yahoo search instead of Google.

Posted

I want to use Google as my search engine but no matter what settings I change the default search engine is always Yahoo.

Also I would like to have the feature back where when I open a new tab it shows frequently used pages that I can click on and open.

Chosen solution

First, thank you to dmcritchie. His solution was helpful. However, I didn't want to uninstall my Yahoo Toolbar because I have buttons, bookmarks, etc. that I don't want to migrate.

For those of you, like me, who wish to continue using your Yahoo Toolbar as well as use the Google Toolbar, here is another solution:

Rather than uninstalling the Yahoo Toolbar, simply hide it. Go to Command Bar, select View > Toolbars > then, uncheck Yahoo Toolbar. (Refer to first image)

Then....

  1. Open a new tab.
  2. Go to the address bar and type in auto:config and hit the enter key.
  3. A warning box will appear. Close the box by clicking on the "I'll be careful, I promise" button. (See second image)

When text comes up,

  1. Scroll down until you find "browser.search.defaulturl" It will be in bold letters. (Third image, with selection highlighted by me)
  2. Right click and select the first option which should be "Modify", then
  3. Type in (or Copy & Paste) the following:
http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

Next,

  1. Scroll down until you find "keyword.URL" It will be in bold letters.
  2. Right click and select the first option which should be "Modify", then
  3. Type in (or Copy & Paste) the following:
 http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

Finally,

  1. Scroll down further until you find "yahoo.ytff.search.popup_src" Again, it will be in bold letters.
  2. Right click on the phrase and select "Modify"
  3. Type (or Copy & Paste) in the following:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

  1. Close the tab

And you're done.

This will allow you to keep all of the buttons and bookmarks that you have on your Yahoo Toolbar without the nasty side effect of having Yahoo hijack your searches and give you those darned 404 Search Error pages.

Hope this helps.

P.S. While you are making changes to auto:config, be sure to copy the values you are changing into a Word Pad document for later recovery. Be clear about what "Preference Name" you accessed and what "Value" you modified. That way, if you have to, you can always go back and return everything to its previous state. I titled my document "Firefox AboutConfig Changes".

Good Luck!

Read this answer in context 38

Additional System Details

This happened

Every time Firefox opened

This started when...

Every time Firefox updates I have to go through the trouble of fixing it

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.43.7
  • Version 2.0.7.0
  • np-mswmp
  • 1.9.0042.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_25 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Wacom Dynamic Link Library

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

I have tried resetting the info but it did not work. I do not have a Yahoo tool bar installed or anything else with Yahoo.

David McRitchie 321 solutions 3089 answers

Helpful Reply

Remove the Yahoo Toolbar

  1. "Ctrl+Shift+A" (Add-ons Manager)
  2. Select Puzzle piece on left-side for Extensions List
  3. Find "Yahoo Toolbar" and click on "Uninstall" button

Then to fix the default search engine used at the Location Bar, change the value of keyword.URL in about:config to one of the values shown in Location Bar search at MozillaZine.

  1. type in about:config into the location bar
  2. if the warning message nonsense comes up uncheck the box before dismissing the dialog message
  3. filter on keyword
  4. right-click on keyword.URL and choose "modify" then paste in the Google search engine string of your choice.

More information on configuration variables available in about:config entries and for users not familiar with the process there is about:config (How to change).

Melanie173 0 solutions 1 answers

Helpful Reply

Shame on you firefox changing my search options in your upgrade. Might reconsider which browser I use. The fact I had to follow such an involved process to turn off a tool bar and reset my default browser is very low - half the people wont be able to do this. This is microsoft tactics.

rocknriter 1 solutions 2 answers

Chosen Solution

First, thank you to dmcritchie. His solution was helpful. However, I didn't want to uninstall my Yahoo Toolbar because I have buttons, bookmarks, etc. that I don't want to migrate.

For those of you, like me, who wish to continue using your Yahoo Toolbar as well as use the Google Toolbar, here is another solution:

Rather than uninstalling the Yahoo Toolbar, simply hide it. Go to Command Bar, select View > Toolbars > then, uncheck Yahoo Toolbar. (Refer to first image)

Then....

  1. Open a new tab.
  2. Go to the address bar and type in auto:config and hit the enter key.
  3. A warning box will appear. Close the box by clicking on the "I'll be careful, I promise" button. (See second image)

When text comes up,

  1. Scroll down until you find "browser.search.defaulturl" It will be in bold letters. (Third image, with selection highlighted by me)
  2. Right click and select the first option which should be "Modify", then
  3. Type in (or Copy & Paste) the following:
http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

Next,

  1. Scroll down until you find "keyword.URL" It will be in bold letters.
  2. Right click and select the first option which should be "Modify", then
  3. Type in (or Copy & Paste) the following:
 http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

Finally,

  1. Scroll down further until you find "yahoo.ytff.search.popup_src" Again, it will be in bold letters.
  2. Right click on the phrase and select "Modify"
  3. Type (or Copy & Paste) in the following:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=

  1. Close the tab

And you're done.

This will allow you to keep all of the buttons and bookmarks that you have on your Yahoo Toolbar without the nasty side effect of having Yahoo hijack your searches and give you those darned 404 Search Error pages.

Hope this helps.

P.S. While you are making changes to auto:config, be sure to copy the values you are changing into a Word Pad document for later recovery. Be clear about what "Preference Name" you accessed and what "Value" you modified. That way, if you have to, you can always go back and return everything to its previous state. I titled my document "Firefox AboutConfig Changes".

Good Luck!

Modified by rocknriter

rocknriter 1 solutions 2 answers

Don't know why the third image disappeared from this site.

Here it is again.

hanhphuc 0 solutions 1 answers

Oh my GOD! Thanks SSSSSSSOOOOOOOOOOOOO much. Never use Yahoo again. Will DELETE everything from yahoo. OOOHHHUUUU.

Question owner

Thank you rocknriter!!! That fixed my problem. At least until the next update. LOL

I really wish FF would find a way not to change all my customization every time they upgrade the software.

Thanks again!

jazvampire 0 solutions 1 answers

What if there ISN'T a "browser.search.defaulturl" perameter listed?

David McRitchie 321 solutions 3089 answers

What if there ISN'T a "browser.search.defaulturl" parameter listed?

That would be good because it has a default value of

GMan 0 solutions 1 answers

Just modifing the keyword.URL worked for me, I simply right clicked it and chose Reset, closed the browser and reopened and I have my Google back!!!

Modified by GMan

jmerch44 0 solutions 1 answers

I am having another problem. If I search by typing in the address bar, a Google search comes up, which is what I wanted, but if I go from the Mozilla homepage search box, a Yahoo search comes up. In about:config I am seeing the following three lines in bold:

yahoo.ytff.general.dontshowhpoffer;true (the only option that comes up here is "Toggle," which toggles between 'true' and 'false,' which didn't fix the problem)

yahoo.ytffp.installer._u;yahoo.ytffp.installer._u;797166663cf147d18e27bcd3c08fb100 (has the option to modify, but putting in the Google string didn't do anything)

yahoo.ytffp.installer.nd;1 (also has the option to modify, but the type is integer, not string, so I didn't touch it)

Any ideas?

billb1111 0 solutions 2 answers

Is there any way to make this change permanent? I cannot tell you how many times I have changed several areas. I have changed the keyword.url, the other areas suggested above, as well as any place that includes Yahoo. It works for the day, but soon (I don't know for sure if it is after any reboot...guess I should check) I am right back at Yahoo taking over my location bar search. I'm eager for more ideas. TIA.

billb1111 0 solutions 2 answers

I just wanted to note that I did a reboot and I have that annoying Yahoo back as my location bar search engine. The regular search box stays with Google and has since I reset it some time ago, but resetting/pasting a change in the location bar search (about:config) seems to last only until reboot. I am using Firefox 5.0. And I am currently running a Windows search for all occurrences of Yahoo on my C: drive...not sure what I'll do with the info, but is seems appropriate to search.  :-)

David McRitchie 321 solutions 3089 answers

You can foil most attempts to change your about:config setting of keyword.URL by setting the preference in user.js file within your profile, which you can modify while Firefox is up, simply add the following two lines (the first of which is a comment).

// override unauthorized attempts to change keyword.URL
user_pref("keyword.URL","http://www.google.com/search?ie=UTF-8&oe=UTF-8&q=");

user.js does not exist by default you have to create the file in your Firefox folder which you can get to quickly through about:support then click on "Open Containing Folder:" and create or modify user.js

More information on user.js in


This is not something that would happen to me as I never allow any external search to occur at the Location Bar except through a keyword shortcut, so there are fewer accidents to be made when searching. I probably havewell over one hundred specialized search keyword bookmarks specifically relating to search engines and most make use of Google.

Modified by David McRitchie

cliffdunaway 0 solutions 2 answers

Menu Bar has to be "on" to change the default search engine. Under Options, turn on Menu Bar. Then click the Yahoo symbol on the search bar.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24395 answers

For those of you who have the search engine on - about:home - the default Firefox 4+ homepage switched to something other than Google, try this.

With the about:home page loaded, paste this in the Location Bar and hit Enter.

 
javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}
 
davidjhardie 0 solutions 3 answers

This is excellent advice, thanks.

It took me a few hours to turn to a forum to find out how to change the search engine in the menu bar..... it is NOT obvious nor easy.

It beggars belief why it is so difficult to change the search engine back to Google, my preferred chioce, from Yahoo when I didn't change it in the first place.

Someone else wrote that this sort of practice smacks of Microsoft. I will add to that Apple.

Mozilla should take note and not get too big for their boots.

We, the users, are not very happy when we are taken down paths we don't want to go down.