Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

install FireFox 3.5x or 3.6x to work with the Federal Student Aid site

  • 3 replies
  • 530 have this problem
  • 1069 views
  • Last reply by Toad-Hall

more options

I have FF 5.0. Need to use Federal Student Aid site and 5.0 will not work with their site. They require FF 3.5x or 3.6x. What can we do? Can I download 3.5 or 3.6 as well and use it when accessing the Federal Student Aid site? Thanks TubeDude

All Replies (3)

more options

Located 3.6 on the mozilla website Try this: [http://www.mozilla.com/en-US/firefox/all-older.html]

more options

Thanks, but that download starts downloading 5.0. I q guess we will have to wait for FF or the Federal Student Aid site to make FF5.0 compatible. What a pig or a mess! tubedude

Modified by tubedude

more options

I've just been to the link and scrolled down the page to find the English (British) 3.6.18 Download . I clicked on it and the Firefox setup 3.6.18.exe asked to download.

If you click on the 'latest version of Firefox' which is in the first paragraph then it will download the 5.0 version.