Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Javascript error when starting Firefox 5

  • 2 replies
  • 138 have this problem
  • 89 views
  • Last reply by jfrancis

more options

I've just upgraded Firefox from 4.0.1 to 5. Now when I start Firefox, the following error message appears:

JavaScript Application TypeError: Components.classes[cid] is undefined

When I click the OK button, Firefox loads. It looks normal, and seems to behave normally. I have Java Version 6 Update 26 installed (Windows XP), which is the latest version.

Seems to be a Firefox problem, as I didn't have it before with the same version of Java installed. Is there a Firefox setting that needs to be changed, or is it maybe a Firefox bug?

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox 4 you can use one of these to start in Troubleshoot Firefox issues using Safe Mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

In Firefox 4 you can use one of these to start in Troubleshoot Firefox issues using Safe Mode:

  • Help > Restart with Add-ons Disabled
  • Hold down the Shift key while double clicking the Firefox desktop shortcut (Windows)

more options

Thank you. The problem appears to have been with the theme "Firefox 3 Theme for Firefox 4+." After switching to the default theme, "Default 5.0," the JavaScript error doesn't appear.