X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I downloaded firefox 5 and then found out it does not support my google toolbare where I have all of my bookmarks. How do I remove 5 and download 4 again?

Posted

I just downloaded firefox 5 and then found out it does not allow me to have my google toolbar. I use the google toolbar for all of my bookmarks. I want to remove firefox 5 and redownload 4 so that I may have my google toolbar back. How do I do this?

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60531.0
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

The GTB 7.1.20110512W version works in Firefox 5.0 by using the Compatibility Reporter extension, I tried it myself due to the large number of postings about the GTB this morning.
https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/

jerjorju 0 solutions 1 answers

THANK YOU!!! Worked like a charm. Firefox help page was of no help. You saved the day.

quickdrawartist 0 solutions 1 answers

Why on earth not prevent freaking people out about losing plugins when they upgrade by including info about the compatibility reporter UP FRONT .... BEFORE the download. This happened to me in a previous "upgrade" and caused me a lot of grief, panic and wasted time. It also makes me very hesitant to upgrade. Are programmers an alien race or something? Don't you get it? Arghhh


moderator edited due to profanity
https://support.mozilla.com/en-US/kb/Forum+and+chat+rules+and+guidelines

Modified by the-edmeister

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

@quickdrawartist

The Compatibility Reporter extension is not meant to "fix" every extension that isn't "compatible" with a new version of Firefox, it is for Alpha & Beta testers to report that an extension works or to report problems with a particular extension. The "developer" of each extension still needs to "update" their product. Each users experience with using the Compatibility Reporter will vary for extensions they have installed.

A couple of us tested the Google Toolbar 7.1.20110512W extension with Firefox 5 after it was released on 6-21 and reported it as being compatible.

Chimel 2 solutions 43 answers

Helpful Reply

@the-edmeister From the number of pages of thread titles related to the Google Toolbar and Firefox 5.0, you should realize something is terribly wrong with Firefox compatibility design.

Developers should NOT have to edit their code every few months because Firefox updates major versions like mad every few months just for the sake of catching up with IE 9 and Chrome 12 version numbers.

This is NOT efficient, generates a lot of redundancy, and is also totally misleading, because Firefox is pushing devs to release a so-called new add-on which is actually strictly identical to the previous version, except for the maximum compatible version number.

Besides, even admitting developers' agenda unlikely happened to match Firefox', they would all specify the same "5.0" number just so their add-on is not disabled, and will investigate possible compatibility issues later on. If they don't specify "999.0" once for all because this process is a joke...

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

@Chimel

Yes, I realize there's a big problem with the new Fast Release cycles, but I am merely a user like almost everyone else who posts here and trys to "help" Firefox users. I don't have ability to change anything in Firefox myself, or to change the manner in which extension versioning of add-ons is handled my Mozilla.

The main thing this past 4 or 5 days I have learned, is that Add-ons not hosted at the official AMO website are the ones causing the largest amount of problems for users. Maybe Mozilla needs to block the installation of Add-ons from anywhere except Add-ons.Mozilla.Org??
https://addons.mozilla.org/en-US/firefox/

Another thing that is apparent is that users didn't learn from what they had happen 3 months ago when Firefox 4.0 came out - some Add-ons aren't updated by their developers in a timely manner. Did they expect different results this time? The issue with the Google Toolbar is something new, they are usually on top of things. But with Yahoo, Norton, Kapsersky, McAfee, and many other add-ons hosted elsewhere, this is nothing new - it happens with every damn major version update since Phoenix 0.2 in 2002. But now it is going to happen 4 or more times a year, instead on every 12 to 14 months, or longer. One of two things is gonna have to happen; either users stop using this crap from outfits that can't keep up with the "pace" or these outfits are going to have to treat their Firefox users better and keep up with Mozilla and the Rapid Release schedule. Or maybe Mozilla is going to lose a few hundred thousand users who don't "get it" and keep making the same mistakes repeatedly and who expect different results - IOW, add-on developers supplting their product in a timely manner.

Bottom line is that Firefox works the way it works. If the maxVersion is set too low for a new version, the extension is going to be disabled. Firefox is not an environment where an add-on developer can create an extension once and have it work forever. Firefox works fine without any extensions, if the user decides to install extensions, that is between them and the developer of those extensions.

In conclusion, I postponed my work for a day this past week to help Firefox users with the 5.0 update and spent almost 16 hours here helping users. For that effort I got too many rude comments and very few thank you's. When Firefox 6.0 comes out, there is liable to be one less "helper" around here - I am planning on taking a day or two off from helping out here.

wLindsay 0 solutions 1 answers

It doesn't work on my FireFox 5.0. Unless you consider popup error messages as 'working'. I too am pretty displeased with Mozilla on this one. Google toolbar, acrobat and others are common enough that mozilla should make sure the most common and popular addons actually work before a release. This nonsense makes me wonder if MS is at work here.

bbox 0 solutions 1 answers

Helpful Reply

@the-edmeister Thanks for helping and still being part of the Firefox community.

Having turned many people on to Firefox over the years and providing informal support IRL, I just see our community being slammed and taking major casualties on the release of every major version, for exactly the reasons you have explained.

A 6 week release cycle - which is the schedule I have read about in reportage - is just stupid if the community of users and developers and supporters means anything at all to those making the decision on the schedule. I've just been completely flabbergasted since I heard about the insanity and haven't attempted to find the justification for it but if, as Chimel says, it is purely to catch up to IE and Chrome, I don't think I can even start to countenance the imbecility behind that decision making process.

A friend of mine who was asked to make a cult TV show by the ABC here in Australia, a couple of decades ago, explained his thought process was to come up with a TV show and then find a way to get 90% of people not to watch it. That pretty much exactly sums up what is going on with the 6 week major release cycle for me. It's going to be what makes 90% of Firefox users stop being Firefox users.

ThomasMurphy 0 solutions 3 answers

SO: what do I do now that 5.0 is said to be incompatible with my Mac? I had 4.0 for years, was happy with it and filled it with all sorts of stuff...Now I can't get back to my original, or any version of Firefox. And..WHERE are all these supposed "volunteers" we're supposed to be able to chat with? I want my Firefox back, and they should give us an easy way to chat and get help!

ThomasMurphy 0 solutions 3 answers

I'm still in need of a solution to my problem, that being the ability to get my previous version of Firefox back on my Mac. Trying to update to 5.0 failed, and there is no one to chat with (it's closed). I am VERY grateful that there is someone like you who is out there willing to help all of us who have been messed up during this upgrading process; I'm just hoping that this "upgrade to 5.0" experiment doesn't turn out to be a complete bust...

vitorazjr 0 solutions 1 answers

It is terrible do not receive any answer for our questions, please see the link bellow to download your version: MAC OS X

http://www.mozilla.com/en-US/products/download.html?product=firefox-4.0&os=osx&lang=en-US

Cheers