Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

after upgrading to firefox 5 default search engine switched from google to http://www1.dlinksearch.com/main?url=cards and cannot get it back to google

  • 15 replies
  • 126 have this problem
  • 2 views
  • Last reply by Jamie100297

more options

what to do. Need help.

moderator locked this thread, as it went off topic and the "owners" problem has been answered

Modified by the-edmeister

Chosen solution

The problem is with my D-Link router. It changed the settings. Follow the link below: http://www.hacksparrow.com/dlinksearch-hijacks-browser-disable-dlinksearch-com-search.html

Read this answer in context 👍 0

All Replies (15)

more options
more options

Downed 5, now cant get google or mcaffe site adviser.....great update mozzila!! Will probably switch to Chrome.

more options

You can try this extension if you have compatibility issues,

more options

Downed it and everything ok now.Many Thanks!!

more options

Please click the Solved It button next to the answer that solved your Firefox support issue (it appears when you are logged in) so this thread gets marked as Solved to help other users who may have this same problem.

more options

Teh link provided did not resolve issue. This is not an add-on issue as I did not install any add-ons when I upgraded to Firefox 5. In fact removed a couple that were not compatible with Firefox 5 (one was Google tool bar other was a video add on to watch TV shows)

more options

Oops, sorry, confused fithawk1 with the original question author mfs4360.

mfs4360, can you check for the issue in a new profile please? Profile Manager - Create, remove or switch Firefox profiles

more options

Cant see the solved it button (logged in)??

more options

McAfee site adviser still not working??

more options

Answer: Go to your home page and search for GOOGLE. After Google shows up, click options and under the General tab click "use current'.

This of course is a work-a-round. I can't find how to "correctly" change my default home page's search engine.

This subject has NOTHING to do with changing the search engine for the "search bar" thank you.

Now my beef. Why on earth would the Firefox team underhandedly change the search on the home page so surreptitiously? If we wanted to change the home page, we would do it!  :-p

more options

Firefox's default on this is Google.

If it gets changed, it is likely to be extension fault. In this case, a new profile should not have this issue.

more options

Gryllida, no, you are wrong. You can believe what you want but you are wrong.

more options

The ONLY problem is with Firefox 5.0!!!

It doesn't matter whether you delete a Search Provider, Change the Order of them or Anything ELSE!!!

Since 5.0 YAHOO has now turned into the DEFAULT SEARCH PROVIDER!!!

Get that through your head. That isn't the only thing that keeps changing. The Home Page does also.

On top of that this was supposed to be more stable then 4.0 but it crashes even more then 4 was. The only time I saw Firefox stay stable was by keeping my PC under 3.0 GHz.

more options

Menu Bar has to be on to change the default search engine. Under Options, turn on Menu Bar. Then click the Yahoo symbol on the search bar.

more options

Chosen Solution

The problem is with my D-Link router. It changed the settings. Follow the link below: http://www.hacksparrow.com/dlinksearch-hijacks-browser-disable-dlinksearch-com-search.html