X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Turning off HTTP referrer header?

Posted

So, there's this one art website I used to go to a lot. I used Firefox to access it and it had no problems before. I decided to return to the website, and now all the thumbnails and photos are replaced with a message saying I have an invalid referer. It's discussed in the FAQ of the website, and says that I have to change the settings on my HTTP referrer header. I have attempted to do so by following the instructions given (setting the value to 2, and when that had problems, to 1), however it only seems to work for a few images . Quoting the FAQ here:


"If you have software on your computer that is filtering the HTTP "referer" header, you will experience problems viewing the site.

Many consumer software firewalls, such as Norton Personal Firewall (which is also part of Norton Internet Security), ZoneAlarm, and McAfee, remove the referrer from HTTP requests which will prevent you from viewing images or downloading files on any site that does a referrer check. Therefore, such options should always be turned off.

(o) For Symantec and Norton Firewalls: Go to the Privacy Settings and disable "Privacy Control". (Please note that "Privacy Control" does not protect your privacy in any way, as your IP address will always be logged regardless of that setting). (o) For ZoneAlarm: Go to Privacy -> Cookie Control -> Custom and uncheck "remove private header information". (o) For McAfee Firewall: Go to Privacy Service -> Protect my Identity -> Erase Revealing Information and uncheck "Prevent Referer Information to be Shared".

If you use a Gecko-based browser, such as Mozilla Suite, Firefox, or Netscape, referrer sending can also be disabled (but by default, it is enabled). To change that setting, browse to "about:config", then search for "network.http.sendRefererHeader". If the value is set to 1 or 2, referrer sending is enabled. If it is set to 0, it is disabled. To enable it, double-click on the setting, then change the value. The default is 2.

If you use Opera, referrer sending can also be disabled. To change that setting, press F12 and check "Enable referrer logging".

Software like AdSubstract also blocks the referrer and makes image viewing impossible.

We're sorry for any inconvenience this may cause and hope you understand our reasons for doing so. Bandwith doesn't come cheap and we have to do all we can to keep the bandwith usage down. This also protects our site from any liability problems that could be caused from bypassing our registration system to view works. "

I'm not posting the URL, for the website may offend some people.

Modified by MarinaMadness

Additional System Details

Sites Affected

http://

Installed Plug-ins

  • iPhoto6
  • 4.0.50917.0
  • Shockwave Flash 10.2 d161
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • DivX Web Player version 2.1.1.94
  • Java Plug-In 2 for NPAPI Browsers
  • Version 2.0.4.2108
  • Google Talk Plugin Video Accelerator version:0.1.43.7

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
cacaoweb
1.0.15
true
cacaoweb@cacaoweb.org
DivX Plus Web Player HTML5 <video>
2.1.1.94
false
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
DivX HiQ
2.1.1.94
false
{6904342A-8307-11DF-A508-4AE2DFD72085}
Illimitux
4.1
true
illimitux@illimitux.net
Modified Preferences
Name
Value
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
dom.disable_window_open_feature.status
false
extensions.lastAppVersion
4.0.1
network.cookie.prefsMigrated
true
network.http.sendRefererHeader
0
places.database.lastMaintenance
1307071861
places.history.expiration.transient_current_max_pages
56371
places.last_vacuum
1303262368
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
0x22600,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
2/2 OpenGL

jscher2000
  • Top 10 Contributor
2359 solutions 20896 answers

Helpful Reply

The system information you posted shows you still have:

network.http.sendRefererHeader = 0

Do you have any add-ons (Extensions) that might manage privacy that could be overriding your change?