X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap

Posted

Recently unable to access my city's water utility site to pay my bill, I can still access it on internet explorer. error message:

Secure Connection Failed

Cannot communicate securely with peer: no common encryption algorithm(s).

(Error code: ssl_error_no_cypher_overlap)

Additional System Details

Sites Affected

https://rrc2gov.net/Click2GovCXP/Index.jsp

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.43.7
  • Version 2.0.7.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60310.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

cleared all history

skypeschematics 0 solutions 1 answers

First, you need to go to about:config. Then enable ciphers support (e.g. security.ssl3.rsa_rc4_40_md5 set to true and so on).

Helpful Reply

turns out had to go to options/encryption and check TLS 1.o and I got that answer from the tech support for the water utility company.

hippiechickkim 0 solutions 1 answers

Helpful Reply

An error occurred during a connection to game3.pogo.com.

Cannot communicate securely with peer: no common encryption algorithm(s).

(Error code: ssl_error_no_cypher_overlap)


I have tried going to OPTIONS and then ENCRYPTION and BOTH boxes are allready checked (SSL 3.0 and TLS 1.0) I tried unchecking one at a time, unchecking and checking of just about everything under encription.... It used to work fine, not sure when exactly it began this when trying to play SCRABBLE on POGO games....

cor-el
  • Top 10 Contributor
  • Moderator
10778 solutions 97004 answers

Which Firefox version are you using (Help > About)?

You can also check the SSL3 and TLS prefs on the about:config page via the location bar.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).